Exim, Imap and pop are all down on server.

MattFulger

Member
Dec 4, 2005
7
0
151
Hi all,

I'm facing a problem where my exim, imap and pop servers all three quit working.

I've tried restarting all three and get errors with each.

For Exim:

Feb 20 17:52:53 server exim: exim shutdown failed
Feb 20 17:52:53 server exim: spamd shutdown succeeded
Feb 20 17:52:54 server exim: /usr/sbin/exim: error while loading shared libraries: requires glibc 2.5 or later dynamic linker
Feb 20 17:52:54 server exim: exim startup failed
exim has failed, please contact the sysadmin.
For Imap:

Waiting for imap to restart...............finished.

authdaemond (/usr/libexec/courier-authlib/authdaemond) running as root with PID 1433

imap has failed, please contact the sysadmin (result was "couriertcpd is not running").
For Pop:

Waiting for cppop to restart...............finished.

authdaemond (/usr/libexec/courier-authlib/authdaemond) running as root with PID 30020

cppop has failed, please contact the sysadmin.
This happened after attempting to fix the databases that disappeared from within cPanel after a security update enabling Suphp. After the security update most of the databases became unusable. In cPanel when you created a DB or user, it said all was fine, but the Database and user never did appear within cPanel or phpmyadin.

I tried a number of suggested fixes to no avail. Then I came across one that "seemed" to work. However, on closer inspection, it didn't really fix the problem. Some scripts are working and some are not. For example WordPress doesn't work now. However, new accounts I make do seem to work (need to test more to know for sure).

Additionally, all the unlimited accounts seem frozen or something. When trying to install something from Fantastico, I get this:

Not enough space available to install WordPress
Disk space required: 10.19 MB
Disk space available: -0.5 MB
and this is on an account that is supposed to have unlimited space.

I've run out of ideas on how to fix these issues.

Any and all help will be greatly appreciated.

Thanks in Advance!

Matt Fulger

P.S. I posted a ticket to support, but I'm behind 50 others so I thought I might get a quicker response if I posted this publicly. I read somewhere that we should post the ticket ID if we have a ticket open so here's the ticket Id 1236325
 
Last edited:

MattLee

BANNED
Aug 26, 2009
83
0
56
For anyone else with similar issues, the problems reported by this user were caused by an out of date operating system due to the package manager being broken.

I'd recommend that users with similar errors go ahead and make sure that their operating system is fully updated as well as all the packages therein.