Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

exim in the process list in Cpanel

Discussion in 'General Discussion' started by ryan.overton, May 12, 2006.

  1. ryan.overton

    ryan.overton Active Member

    Joined:
    Mar 3, 2006
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    156
    "exim (package exim is not installed)"

    but yet, exim is running. It used to show a version number, but now it says the package is not installed.
     
    #1 ryan.overton, May 12, 2006
    Last edited: May 12, 2006
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    4
    Trophy Points:
    193
    Location:
    Minneapolis, MN
    You need to force install exim at the prompt:
    /scripts/eximup --force
    then
    /scripts/upcp --force
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. ryan.overton

    ryan.overton Active Member

    Joined:
    Mar 3, 2006
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    156
    after I did that, none of my mail works anymore

    this is what I keep getting.

    Code:
    2006-05-12 18:24:58 failed to expand condition "${perl{check_deliver_spam}{$domacheck_deliver_spam called.
    
    2006-05-12 18:24:58 failed to expand condition "${perl{checkbx_deliver}{$domain}::checkbx_deliver called.
    
    2006-05-12 18:24:58 failed to expand condition "${perl{check_deliver}{$domain}{$ver called.
    
    2006-05-12 18:24:58 H=(RhinoWest) [67.47.19.6] sender verify fail for <rhino-163
    2006-05-12 18:24:58 H=(RhinoWest) [67.47.19.6] F=<rhino-1631joebattle@watsontayl
    2006-05-12 18:24:59 fixed_login authenticator failed for (LORIO) [71.96.226.61]:ined subroutine &main::checkuserpass called.
    
    2006-05-12 18:25:01 fixed_login authenticator failed for (LORIO) [71.96.226.61]:ined subroutine &main::checkuserpass called.
    
    2006-05-12 18:25:04 fixed_login authenticator failed for (John) [216.73.173.50]: 435 Unable to authenticate at present (set_id=bnky@biggerslawfirm.com): Undefined subroutine &main::checkuserpass called.
    
     
  4. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    4
    Trophy Points:
    193
    Location:
    Minneapolis, MN
    Make sure exim.pl and/or exim.conf are not missing.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    22
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Well, exim.pl clearly is missing.

    This usually happens if you chattr any of the exim configuration files. Firstly use lsattr and make sure no flags are set on the exim files in /etc/exim* if they are, remove them. Then make sure none of your disk partitions are out of space, then rerun the /scripts/eximup --force. Lastly, if you're running FedoraCore, make sure exim is in the exclude list in yum.conf
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice