The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim: incompatible command-line options or arguments

Discussion in 'E-mail Discussions' started by equens, Jan 27, 2011.

  1. equens

    equens Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    270
    Likes Received:
    0
    Trophy Points:
    16
    Hello, default queue and pending stopped yesterday from last update of Cpanel/MailScanner FE:

    I can´t deliver all Messages in queue from WHM:

    Delivering All Messages in Queue
    exim: incompatible command-line options or arguments
    Complete.

    WHM 11.28.64
    CENTOS 4.8 i686 standard

    Any help will be appreciated!
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,455
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Check your: WHM > Service Configuration > EXIM Configuration Editor, page for messages. Do you have any customizations to EXIM?
     
  3. equens

    equens Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    270
    Likes Received:
    0
    Trophy Points:
    16
    All appears correctly, I have the same error in two differents servers.


    queue_only_override = false
    no_message_logs
    log_selector = +arguments +subject +received_recipients
    timeout_frozen_after = 4d
    ignore_bounce_errors_after = 2d
     
    #3 equens, Jan 27, 2011
    Last edited: Jan 27, 2011
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,455
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Interestly enough, I have no mail stuck in the queue but clicked "Attempt to Deliver all messages in queue" and get the same message as you:

    exim: incompatible command-line options or arguments

    That server is running the latest CURRENT. On my EDGE server doing the same thing seems to work as expected in that I do not get that message.
     
  5. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    I do not see a bug report about this issue. Infopro, when you indicate you are running the latest CURRENT, is that 11.28.75 that's listed in http://httpupdate.cpanel.net page? EDGE is also on 11.28.75, so that's why I'm asking, while 11.28.64 is latest RELEASE and STABLE.

    equens, can you open up a ticket using WHM > Support Center > Contact cPanel or via the link in my signature about this issue? If you believe it might be a bug, please use the Bugs link at the top right of the forum or http://go.cpanel.net/bugreport link.

    Also, is there a reason you do have "queue_only_override = false" set on the machine? I do wonder if a queue setting is impacting it. I am not entirely certain the purpose of that setting after reviewing it in http://www.exim.org/exim-html-current/doc/html/spec_html/ch14.html location, so if you could explain why it's set on the servers precisely anyway.
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,455
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    CURRENT 11.28.75 yes, EDGE here is at 11.28.71

    I meant to post back here but got sidetracked. I did do some testing on these 2 servers removing all of those entries, adding them back one by one saving and checking again and none of them are affecting this on either server.

    I removed all the lines and reset EXIM to defaults on both servers as well.

    When I cick the link to "Attempt to Deliver..."

    On EDGE:

    LOG: MAIN
    cwd=/usr/local/cpanel/whostmgr/docroot 2 args: /usr/sbin/runq -v
    LOG: queue_run MAIN
    Start queue run: pid=5740
    LOG: queue_run MAIN
    End queue run: pid=5740
    Complete.

    On CURRENT:

    exim: incompatible command-line options or arguments
    Complete.
     
  7. cPanelKyle

    cPanelKyle Technicial Analyst III/Migrations Specialist
    Staff Member

    Joined:
    Feb 10, 2003
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Twitter:
    I attempted to replicate this using 11.28.75-EDGE_51144 and 11.28.75-CURRENT_51144 and cannot. Infopro are you using MailScanner on your server as well like the original poster?
     
  8. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,455
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I apologize for that, forgot to mention it. Yes, on the server running CURRENT.
     
  9. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Infopro, would you be willing to uninstall MailScanner on that machine to see the results? Good catch, Kyle!
     
  10. equens

    equens Well-Known Member

    Joined:
    Feb 8, 2002
    Messages:
    270
    Likes Received:
    0
    Trophy Points:
    16
    Hello,

    ::: Official Home Page for MailScanner - Anti-Virus and Anti-Spam Filter :::

    Deferring incoming messages

    There are a couple of ways to prevent Exim from delivering messages immediately. The simplest is to add this line to the first part of the configuration file:

    queue_only = true

    However this allows Exim's admin users to bypass MailScanner using Exim options such as -q and -M, and if you have prod_requires_admin = false then any user can do this.

    In Exim-4.21 and greater you should use an additional setting to make the queue_only option stronger:

    queue_only_override = false
     
  11. Gene Steinberg

    Gene Steinberg Well-Known Member

    Joined:
    May 26, 2007
    Messages:
    157
    Likes Received:
    1
    Trophy Points:
    18
    There's a warning from MailScanner's publisher that if you uninstall, stuck outgoing mail is lost.

    I have a problem like this as well, but nothing here seems to be of help.

    Peace,
    Gene
     
  12. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello Gene,

    Have you posted on the MailScanner site to ask about the issue you are having with their product?

    Thanks!
     
  13. Gene Steinberg

    Gene Steinberg Well-Known Member

    Joined:
    May 26, 2007
    Messages:
    157
    Likes Received:
    1
    Trophy Points:
    18
    Yeah, but we managed to free the queue by then. Still getting that exim error message, but it appears to be a CSF issue with the way MailScanner works with Exim. This is, frankly, a product that ought to be part of the core cPanel installation, as basic spam filtering is not terribly good without it. Better than Plesk, but it could still be improved.

    Peace,
    Gene
     
  14. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If MailScanner is still installed and you are receiving this error message, then it would be MailScanner that is causing the error message (as the prior 2 posters also had it happen only on systems with MailScanner). If MailScanner is no longer installed and you've reset exim to the defaults to troubleshoot the issue and it is still happening, please open up a ticket for us to investigate further.
     
  15. Gene Steinberg

    Gene Steinberg Well-Known Member

    Joined:
    May 26, 2007
    Messages:
    157
    Likes Received:
    1
    Trophy Points:
    18
    Uninstalling MailScanner can empty the mail queue. More to the point, the error is evidently not significant. According to Sarah at CSF, just use their CSF mail queue, part of the MailScanner setup if they install it for you. That way it should work if you have a packed mail queue.

    Peace,
    Gene
     
Loading...

Share This Page