Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Exim is blocking an ip address

Discussion in 'General Discussion' started by elleryjh, Jul 5, 2004.

  1. elleryjh

    elleryjh Well-Known Member

    Apr 12, 2003
    Likes Received:
    Trophy Points:
    I set up a script on one server, lets call it "A" to be able to 'ping' (open and close a connection on) a second server "B" on several critical ports (i.e. 25, 80...) to check for active services.

    So server A is opening connections to server B frequently on several ports and it's working like a charm... until suddenly port 25 (exim) stops reponding to server A. It still works from every other computer.

    I have searched (grep) /etc and /var/log and there are no indications that the ip address was blocked from there.

    So my question is: where is exim or another system component blocking server A?

    serverA[root]# telnet 25
    telnet: Unable to connect to remote host: Connection refused

    C:\myHomePC>telnet 25 ESMTP Exim 4.34 #1 Mon, 05 Jul 2004 20:56:23 -0400
    220-We do not authorize the use of this system to transport unsolicited,
    220 and/or bulk e-mail.

  2. casey

    casey Well-Known Member

    Jan 17, 2003
    Likes Received:
    Trophy Points:
    It's the pop before smtp setup. Your home computer is authorized because you have logged into pop before telneting to the smtp port.
  3. chirpy

    chirpy Well-Known Member

    Jun 15, 2002
    Likes Received:
    Trophy Points:
    Go on, have a guess
    casey, I don't think it will be POP before SMTP. You should still always be able to connect to port 25 (anyone should), it just you won't be able to relay any email through the server without prior authentication.

    elleryjh, do you have APF installed, or some other iptables firewall on either server? You could check both servers for blocked ip addresses with:

    iptables -L -n | grep other-servers-ip-address

    Do that on both servers. If that doesn't match have you perhaps enabled the WHM > Security Tweaks > SMTP Tweak on which might be preventing outgoing connections on port 25 to anyone other than root and mailman, etc.?
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice