Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Exim is not removing old email from mail queue

Discussion in 'E-mail Discussion' started by 10101, Jan 30, 2006.

  1. 10101

    10101 Well-Known Member

    Joined:
    Sep 4, 2003
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    166
    Hi,

    I have noticed exim is not clearing the old email from the mail queue, there are thousands of emails in there going back upto 20 days.

    Any ideas?

    Thanks.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Tagor

    Tagor Well-Known Member

    Joined:
    Mar 6, 2004
    Messages:
    193
    Likes Received:
    0
    Trophy Points:
    166
    Run:

    /scripts/reseteximtodefaults
    /scripts/exim4
    /scripts/restartsrv_exim

    This will reinstall exim.
     
  3. 10101

    10101 Well-Known Member

    Joined:
    Sep 4, 2003
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    166
    Hi,

    Thanks but that won't fix it, ive tried /scripts/eximup --force which is what

    /scripts/reseteximtodefaults
    /scripts/exim4

    both do (without force)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Murtaza_t

    Murtaza_t Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    476
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Earth
    cPanel Access Level:
    Website Owner
    Try this :

    pico /etc/exim.conf

    Set ignore_bounce_errors_after = 7d (standard) Or what ever you like.
    Restart exim.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. 10101

    10101 Well-Known Member

    Joined:
    Sep 4, 2003
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    166
    I've tried this too, i have it set to 4 days.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. dr2web

    dr2web Active Member

    Joined:
    Jan 14, 2005
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    156
    I am having the same issue, and my setting reflects:

    ignore_bounce_errors_after = 7d

    Is there any other workaround?
     
  7. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    920
    Likes Received:
    13
    Trophy Points:
    168
    cPanel Access Level:
    Root Administrator
    Try this, WHM>>>>>>>>Exim Configuration Editor >>>>>>>>>Advanced mode. Then in the first white box type:
    Code:
    timeout_frozen_after = 2d
    ignore_bounce_errors_after = 2d
    Adjust days to your taste and hit save at bottom of page. ( yep, you can do this with vi /etc/exim.conf )
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #7 kernow, Feb 9, 2006
    Last edited: Feb 9, 2006
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice