The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim is not working. 503 valid RCPT command must precede DATA

Discussion in 'General Discussion' started by cool38, Aug 3, 2006.

  1. cool38

    cool38 Member

    Joined:
    Aug 1, 2006
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    after i have upgraded to the latest version of cpanel, and rebooted my server, my exim server is not working properly.

    therefore, i just did a quick check,

    exim is running (with no problem)

    /etc/init.d/antirelayd status
    antirelayd (pid 3002) is running...

    and i ran
    /scripts/fixrelayd

    root@host [/scripts]# ./fixrelayd
    old entry removed
    Updating Syslogconf
    Shutting down kernel logger: [ OK ]
    Shutting down system logger: [ OK ]
    Starting system logger: [ OK ]
    Starting kernel logger: [ OK ]
    Shutting down antirelayd: [ OK ]
    Starting antirelayd: [ OK ]
    root@host [/scripts]#



    with no problem,

    and i found
    root@host [/scripts]# service sendmail restart
    Shutting down sm-client: [FAILED]
    Shutting down sendmail: [ OK ]
    Starting sendmail: [ OK ]
    Starting sm-client: exim abandoned: unknown, malformed, or incomplete option -L
    [FAILED]


    also, i've found this under my mail log,

    2006-08-03 18:41:15 H=2xx-1xx-2xx-xx.static.bxxx.com (xp) [xxx.xxx.xxx.xx] F=<xxx@xxx.com> rejected RCPT <xxx@gmail.com>: 2xx-1xx-2xx-xx.static.bxxx.com (xp) [xxx.xx.xx.xx] is currently not permitted to relay through this server. Perhaps you have not logged into the pop/imap server in the last 30 minutes or do not have SMTP Authentication turned on in your email client.


    could anyone tell me how i can fix this problem, please?
    receving mails are fine, but none of my user could send emails.

    Thanks
     
    #1 cool38, Aug 3, 2006
    Last edited: Aug 3, 2006
  2. tweakservers

    tweakservers Well-Known Member

    Joined:
    Mar 30, 2006
    Messages:
    379
    Likes Received:
    0
    Trophy Points:
    16
  3. nxds

    nxds Well-Known Member

    Joined:
    Jan 6, 2006
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    It's not service sendmail start but service exim start. The latter starts antirelayd amongst other things which implements POP before SMTP auth.

    Try service sendmail stop then service exim start to fix.

    If your server is starting sendmail instead of exim on reboot then you need to fix that too.
     
  4. cool38

    cool38 Member

    Joined:
    Aug 1, 2006
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    i've got this fixed by cpanel support team.

    root@host [/scripts]# ./restartsrv_exim
    Starting exim: [ OK ]
    Starting exim-smtps: [ OK ]
    Starting antirelayd: [ OK ]
    Starting spamd: [ OK ]
    Starting antirelayd: [ OK ]
     
Loading...

Share This Page