The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim issues

Discussion in 'General Discussion' started by Zion Ahead, Mar 19, 2007.

  1. Zion Ahead

    Zion Ahead Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    Not quite sure why this is happening. A few strange issues

    - exim_mainlog starts at 03/18/2007 (not aware of any rotating log crons)
    - grep info@someexternaldomain.com /var/log/exim_mainlog is empty, even after sending to that email from localdomain.com today, a few times
    - localdomain.com is found fine in localdomains, trueuserdomains\
    - localdomain.com sent just fine to another local domain on server plus gmail account. Delivery receipt to both domains plus the info@someexternaldomain.com were "succesful"

    I've received from info@someexternaldomain.com many times back and forth without issues, yet today nothing shows up in exim_mainlog NOR any other logs inside /var/log

    Any suggestions?

    Logs:

    Code:
    2007-03-19 16:37:01 cwd=/var/spool/exim 4 args: /usr/sbin/exim -odi -Mc 1HTPXJ-0003by-8z
    2007-03-19 16:37:01 1HTPXJ-0003by-8z User 0 set for local_delivery transport is on the never_users list
    2007-03-19 16:37:01 1HTPXJ-0003by-8z == root@host.mydomain.com.com (root@host.mydomain.com.com) <root@host.mydomain.com.com> R=localuser T=local_delivery defer (-29): User 0 set for local_delivery transport is on the never_users list
    
    2007-03-19 16:36:55 1HTPXD-0003bN-GY Completed QT=0s
    2007-03-19 16:37:01 cwd=/var/spool 7 args: /usr/sbin/sendmail -FCronDaemon -i -odi -oem -oi -t
    2007-03-19 16:37:01 1HTPXJ-0003by-8z <= root@host.mydomain.com.com U=root P=local S=712 T="Cron <root@unsurpassable> lynx --dump \"http://domain.com/support/cron.php\"" from <root@host.mydomain.com.com> for root
    2007-03-19 16:37:01 cwd=/var/spool/exim 4 args: /usr/sbin/exim -odi -Mc 1HTPXJ-0003by-8z
    2007-03-19 16:37:01 1HTPXJ-0003by-8z User 0 set for local_delivery transport is on the never_users list
    2007-03-19 16:37:01 1HTPXJ-0003by-8z == root@host.mydomain.com.com (root@host.mydomain.com.com) <root@host.mydomain.com.com> R=localuser T=local_delivery defer (-29): User 0 set for local_delivery transport is on the never_users list
    Are these logs normal for the most part?

    I already ran a few scripts *prior* to these logs AND unchecked all options whm > exim config

    eximup --force
    fixmailman
    mailperm
     
  2. krprahlad

    krprahlad Member

    Joined:
    Feb 9, 2007
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    > User 0 set for local_delivery transport is on the never_users list

    1) Comment "never_users = root" line in exim.conf file.

    2) Restart exim

    If now also you see the same error try to do these steps.

    1) Delete /etc/eximmailtrap file
    2) Disable /var/cpanel/cpanel.config by
    putting eximmailtrap=0

    One of these steps should solve this error. :cool:
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You should not edit /etc/exim.conf as it will be overwritten, you can simply redesignate that option through the exim configuration editor.

    IIRC, you get those errors if you haven't set the root forwarder in WHM > Change System Mail Preferences
     
  4. krprahlad

    krprahlad Member

    Joined:
    Feb 9, 2007
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Thank You very much for your information chirpy. :)


    Can you please tell me what more can be added in "WHM > Change System Mail Preferences" ?

    Thanks,
     
Loading...

Share This Page