The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim keeps failing?

Discussion in 'General Discussion' started by snet, Feb 15, 2006.

  1. snet

    snet Active Member

    Joined:
    May 16, 2004
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    Hello,

    On one of my cPanel servers exim keeps failing. I keep on getting the following emails about one every 50 minutes:

    exim failed @ Wed Feb 15 14:03:35 2006. A restart was attempted automagicly.

    How can I find out what is causing exim to fail and how can I fix this?


    Thanks.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You need to look in the exim log files. The exim_mainlog contains all the transaction details. Normally, the exim_paniclog will have a filtered list of major events. Also, if you have something like PRM installed, make sure it isn't that killing it off.
     
  3. snet

    snet Active Member

    Joined:
    May 16, 2004
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    Hello Chirpy,

    I have looked in both exim_mainlog and exim_paniclog but there is so much stuff in them that it is hard to find anything. What sort of stuff should I be looking for in these files?
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Your exim_paniclog should be almost empty since only the most serious errors go into it. You're simply going to have to match up the time of the restart of exim less ~0-10 minutes and look through errors. As I also mentioned, you should check if you have any processing killing apps installed too.
     
  5. snet

    snet Active Member

    Joined:
    May 16, 2004
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    I am not running anything like PRM on this server. Exim has just failed again and I looked at the exim_mainlog file and around the time it failed there is a bunch of lines like the following:

    (Hostname and IP address edited out for privacy)

    And then after all of these lines is says:

    I guess this bit is when cPanel restarts exim. Before the "SIGTERM" lines there is nothing unordinary, just loads of lines like this:

    And a few others that are repeated throughout the log file.

    Any ideas? :)
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    It's probably this:
    Which looks like someone running a DOS against exim, unless you recognise the IP address. If not, block it in iptables. Do you have any custom ACL's in the exim configuration? If so, make sure that none of them use delay
     
  7. snet

    snet Active Member

    Joined:
    May 16, 2004
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    I don't recognise the IP addresses, each one is completely random, the same IP address isn't repeated once.


    I don't think so, I believe exim is running with the stock config at the moment.
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Have you:

    1. Made sure any instances of :blackhole: are replace with :fail: in /etc/valiases/*

    2. Installed a dictionary attack ACL:
    http://www.configserver.com/free/eximdeny.html

    That will usually free up a lot of such connections.

    Ultimately, if you genuinly have a very busy email server (it would have to be very busy) you could increase the smtp connections available, but what you're seeing is usually indicative of mis-use of the SMTP server in some manner.
     
  9. snet

    snet Active Member

    Joined:
    May 16, 2004
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    UK
    Hi Chirpy,

    Thanks for your help so far. I have done these 2 things, following the instructions exactly, and exim still fails every 40-50 minutes. Is there anything else I can do to fix this? :)
     
  10. goodmove

    goodmove Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    How do you increase the number of SMTP connections available??
     
  11. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The default is 100, you can up that by setting the following in the first textbox of the exim configuration editor:

    smtp_accept_max = 150
     
Loading...

Share This Page