The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim like open relay problem

Discussion in 'General Discussion' started by classic2009, Dec 13, 2009.

  1. classic2009

    classic2009 Member

    Joined:
    Dec 13, 2009
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    hi,

    i have cpanel with exim as mail server
    i checked if it is open relay and it is not
    i disable user nobody to send mails (php and cgi)
    but i have spammers in my server, don't know how
    they send mails from my server, when i check the
    cpanel mail queue i saw that thay send mails from
    domains doesn't exists in my server,so i telnet to
    myserver

    telnet localhost 25

    helo localhost

    mail from:m@hotmail.com

    rcpt to:m@hotmail.com
    accepted

    data
    test
    .

    quit

    and it send the mail,so localhost can send any emails he wants
    (m@hotmail.com) is not localdomain!!!!

    so how i disable localhost from sending mails except if
    the sender is a real user @ my real local domain

    please help me, my server now in blocked, because it send more and
    more spams.

    thanks.
     
  2. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
  3. classic2009

    classic2009 Member

    Joined:
    Dec 13, 2009
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    thanks

    but i want too that localhost cant send emails with fake sender from
    my server like i did with telnet command.
     
  4. classic2009

    classic2009 Member

    Joined:
    Dec 13, 2009
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    please need help
     
  5. classic2009

    classic2009 Member

    Joined:
    Dec 13, 2009
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    hi,

    my issue i am new to exim and cpanel
    i just prefare sendmail with my manual configuration .

    so i run netstat -panel | grep :25

    and i saw perl (x.pl) scripts run on port 25

    so i did ps -ef | grep x.pl

    and saw the user how run the scripts and suspend his account

    and closed port 25 from remote connection too by iptables .

    till now tho spammer stopped, so my be it solved .

    thanks
     
  6. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Emails won't work if you close down port 25. The remote mail servers won't be able to connect to your mail server and emails won't come in so remove port 25 from iptables.
     
  7. classic2009

    classic2009 Member

    Joined:
    Dec 13, 2009
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    hi,

    yes i know, i am disable only for some time, just to watch the log
    for my server when relay, and i opened today.

    thanks for your support.
     
Loading...

Share This Page