The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim: mail from one domain is sent by another domain

Discussion in 'E-mail Discussions' started by krissyhissy, Jun 11, 2006.

  1. krissyhissy

    krissyhissy Registered

    Joined:
    Jun 11, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Still struggling with the following problem:

    I have two accounts on the same server, domain1.com, domain2.com
    When I send mail through PHP from domain1.com all is fine.
    When I send mail from domain2.com, I get this receive line in messages:
    Received: from $user_at_domain2 by domain1.com with local (Exim 4.52)
    That is, domain1.com (the primary domain) sends mail for domain2.com
    Also, even when I send from domain2.com, server sends an EHLO domain1.com during mail sending.

    In a word, domain1.com sends all mail, even if it should be done from domain2.com

    This creates problems as some remote mail servers reject mail from domain2.com because of such mismatch.

    I've tried using local_interfaces and interface commands in exim.conf, but this only binds exim to either domain1.com or domain2.com, depending on what I write in exim.conf.

    Is there a solution for this ? I've searched the forums, to find the same question asked in different ways with no solutions. I've searched the web, where no apparent answers were found. I've tried running two exim daemons, each with their own exim.conf, and using -C command to specify the correct configuration file. This didn't work either as I only have on php.ini where I can specify path to sendmail. I think I also found a way where I can specify different settings for each domain, but that didn't work as I couldn't use the -C option in php.ini due to setuid issues. To bypass setuid issues I had to recompile Exim. I figured geesh, Exim is controlled by Cpanel, let me see if there is another way first.

    Is there another way ?

    EDIT: another problem unsolved.
     
    #1 krissyhissy, Jun 11, 2006
    Last edited: Jun 13, 2006
Loading...

Share This Page