The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Mail Queue

Discussion in 'E-mail Discussions' started by marahibsat, Jul 26, 2008.

  1. marahibsat

    marahibsat Member

    Joined:
    Jul 26, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Sorry if I didn't take time to read all the threads, but my question is very urgent :)
    My registered members stopped receiving emails from the server and I can see all those emails are in the mail queue (more than 10000 messages):(

    I don't know how to solve this problem, if I try to deliver only one mail for example, I got this message :

    And if I look in statistics emails, I can see :

    Thx for your help
     
  2. marahibsat

    marahibsat Member

    Joined:
    Jul 26, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Anyone to help please :)
     
  3. freshorange

    freshorange Well-Known Member

    Joined:
    Dec 26, 2007
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    i have the same problem.
    anyone can help?
     
  4. k.agashe

    k.agashe Member

    Joined:
    May 23, 2006
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    Seems like yahoo is not accepting mail traffic from your server, you need to make sure whether the server IP address is blocked for spamming reasons .
     
  5. marahibsat

    marahibsat Member

    Joined:
    Jul 26, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Not only yahoo but also gmail, hotmail ...ect
    I don't think it's related to spamming cos it was working before :)

    I was supprised today to see the number of messages in queue back to :
    But I don't think 8000 messages are delivered cos I am also registered and I didn't receive anything, sure they were automatically deleted :(

    I hope someone give me the best settings to let it work always, thx in advance :)
     
  6. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,279
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    It's impossible for anybody to give you the 'best settings' - You need to figure out if Google/Hotmail/Yahoo/whoever is purposefully refusing connections from your server IP address or if their actual mail systems are burdened at the time and cannot deliver. You need to make sure you have your mail set up properly, with proper reverse DNS in place. You need to make sure that spam isn't being sent from/through your server. If you say it isn't, I don't think you can guarantee that it isn't. Thousands of messages for Yahoo / Gmail accounts just sitting in your mail queue can certainly be indicative of a spam problem on your server. I don't know how many customers you have on your server, or how often they send mail to their free email accounts @yahoo or @gmail, but thousands of queued messages seems high unless you have a very large number of accounts with a large number of email users.

    You also need to see if those emails are emails destined for one of the domains hosted on your machine which in turn your client is forwarding to their Gmail / Yahoo accounts. For instance, we have people who don't bother to turn on Spamassassin and filter mail and instead set up only a forwarder - Users like to just set up 'forwarders' instead of POP3 accounts - and they forward them to their Yahoo/Gmail/Hotmail/etc accounts - and if your users just set up forwarders, NO spam is filtered - which means that any mail sent to user@some_domain_hosted_on_your_server.com get forwarded to their Gmail/Yahoo/Hotmail etc email accounts, spam included.

    You need to do some investigating, that is the bottom line.

    Mike
     
  7. thewebhosting

    thewebhosting Well-Known Member

    Joined:
    May 9, 2008
    Messages:
    1,201
    Likes Received:
    1
    Trophy Points:
    38
    Have you added PTR (rDNS) record for your server IP address? Some servers do not accept emails without it.
     
  8. marahibsat

    marahibsat Member

    Joined:
    Jul 26, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    thx mike and the webhosting for your answers :)
    I did a look on WBH manager but didn't find where to set PTR reverse DNS, thx for let me know :)
     
  9. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,279
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    If the hostname you have associated with your main IP address is blah.server.com, then contact your dedicated server provider/noc and have them add an RDNS entry.

    Typically, unless you are fortunate enough to have direct control of your reverse zone (most people with dedicated / colocated boxes do not), then you'll need to have your upstream provider or your colocation provider do it for you.

    Ask them:

    Please add a reverse DNS entry for aaa.bbb.ccc.ddd (where aaa.bbb.ccc.ddd is the main IP of your server) so that it reverse resolves to blah.server.com.

    You can see if you have rDNS active by doing:

    dig ddd.ccc.bbb.aaa.in-addr.arpa PTR
    (if your ip is 192.168.1.10, it would be dig 10.1.168.192.in-addr.arpa PTR)
    or
    nslookup aaa.bbb.ccc.ddd

    Test both from on the machine itself and also from an offsite machine. dig will work in Linux, nslookup will work on windows.

    Mike
     
    #9 mtindor, Jul 29, 2008
    Last edited: Jul 29, 2008
  10. marahibsat

    marahibsat Member

    Joined:
    Jul 26, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    thx mike for your quick answers, when I did nslookup in windows :
    nslookup 66.187.105.180.in-addr.arpa PTR
    I haven't reverse active, I will ask the host for it hoping that it will solve email problems :(
    Thx again lovely people :)
     
Loading...

Share This Page