The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim/Mail Segfaults and mail delivery fails when using MBOX on CURRENT

Discussion in 'E-mail Discussions' started by kenrbnsn, Jun 7, 2007.

  1. kenrbnsn

    kenrbnsn Active Member

    Joined:
    Feb 27, 2002
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Hillsborough, NJ, USA
    This morning I woke up to NO NEW MAIL in any of my mailboxes. When I check the mailqueue through WHM, I discovered all the mail was in the queue waiting. When I tried to deliver any of the messages, these messages are displayed:

    Message 1Hw9OM-0004vd-MW is not frozen
    LOG: MAIN
    cwd=/usr/local/cpanel/whostmgr/docroot 4 args: /usr/sbin/exim -v -M 1Hw9OM-0004vd-MW
    delivering 1Hw9OM-0004vd-MW
    LOG: MAIN
    <kenrbnsn@rbnsn.com>: virtual_sa_userdelivery transport output: An error was detected while processing a file of BSMTP input.
    LOG: MAIN PANIC
    == kenrbnsn@rbnsn.com R=virtual_sa_user T=virtual_sa_userdelivery defer (-24): Transport filter process failed (127): unable to execute command

    This started about 7 hours ago when the nightly updates are usually applied.

    How can this be fixed, since none of my customers are receiving email either. :(

    WHM 11.1.0 cPanel 11.4.0-R13357
    FEDORA 1 i686 - WHM X v3.1.0

    Ken
     
    #1 kenrbnsn, Jun 7, 2007
    Last edited: Jun 7, 2007
  2. kenrbnsn

    kenrbnsn Active Member

    Joined:
    Feb 27, 2002
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Hillsborough, NJ, USA
    It seems that something is wrong with SPAMD and it is not starting correctly. Neither is eximstats. I disabled both and the email is being delivered -- without the benefit of spamassassin doing its work.

    Ken
     
  3. AusDataHost

    AusDataHost Member

    Joined:
    Feb 18, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Iv got similar problems here, any ideas?
     
  4. iSage

    iSage Registered

    Joined:
    Jun 14, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Brisbane
    Mail still in queue

    same here.

    Looks like disabling spamassasin after the event is no good.

    One work-around suggested to me was to forward mail to an account off site.
     
  5. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Try this

    /scripts/upcp --force
    /scripts/buildeximconf
    /scripts/restartsrv exim
     
  6. noorolhoda

    noorolhoda Active Member

    Joined:
    Jul 19, 2004
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    It didn,t work for me , any other idea ?
     
  7. HollyRidge

    HollyRidge Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    138
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Garner NC USA
    cPanel Access Level:
    Root Administrator
    Are you still running the old mbox format? If so that could be your problem. I got summoned into the office this morning (at around 1am) to fix several servers with this issue.

    /scripts/convert2maildir

    that will tell you which type you are running. If it tells you that maildir is not active and you are using mbox format then you will need to process the update and conversion.
     
  8. Cristian99

    Cristian99 Active Member

    Joined:
    Jun 17, 2005
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    No solution?
    7 hours without email

    CPANEL TECH ARE YOU HERE??
     
  9. forlinuxsupport

    forlinuxsupport Well-Known Member
    PartnerNOC

    Joined:
    Dec 22, 2004
    Messages:
    386
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    open a support request with cpanel

    then you can post their solution here so you can help all of us :)
     
  10. forlinuxsupport

    forlinuxsupport Well-Known Member
    PartnerNOC

    Joined:
    Dec 22, 2004
    Messages:
    386
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    convert to Maidlir to fix the issue :)
     
  11. noorolhoda

    noorolhoda Active Member

    Joined:
    Jul 19, 2004
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    It worked !
    Thanks
     
  12. Cristian99

    Cristian99 Active Member

    Joined:
    Jun 17, 2005
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    YESSSSSSSSSSSSSS!!!!!!!!!!!!!!!!!!!
    WORK

    I FIXED 25 SERVER:( TOO WORK

    BUT NOW is better update CPANEL?
     
  13. bradyb

    bradyb Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Mail not coming in but sitting in Mail Queue Manager

    SORRY.. posted in wrong Forum section: visit http://forums.cpanel.net/showthread.php?t=67524


    Mail is not coming in but I see them in Mail Queue Manager. This started last night.

    WHM 11.1.0 cPanel 11.2.1-C11635
    FEDORA 3 i686 - WHM X v3.1.0

    Server Configuration >> Update Config

    Config:
    Cpanel: Manual and Current

    Package Updates: Automatic

    Security Package Updates: Automatic

    All services are up

    imap up
    cpsrvd up
    pop up
    syslogd up
    eximstats up
    exim (exim-4.66-3_cpanel_smtpctl_av_rewrite_mm2_mmmtrap_exiscan_md5pass) up
    ftpd up
    named (9.2.5) up
    spamd up
    mysql (4.1.22-standard) up
    exim-587 up
    httpd (1.3.37 (Unix)) up
    Server Load 0.34 (4 cpus)
    Memory Used 9 %
    Swap Used 0.00 %
    Disk /dev/sda6 (/tmp) 2 %
    Disk /dev/sda7 (/home) 22 %
    Disk /dev/sda1 (/) 75 %
    Disk /dev/sda2 (/usr) 40 %
    Disk /dev/sda3 (/var) 39 %


    Exim Configuration Editor


    Main >> Service Configuration >> Exim Configuration Editor

    Standard Options
    Always set the "Sender:" header when the sender is changed from the actual sender. Unchecking this will stop "On behalf of" data in Microsoft(R) Outlook, but may limit your ability to track abuse of the mail system.
    CHECKED: Verify the existence of email senders.
    CHECKED: Use callouts to verify the existence of email senders.
    Instead of showing the reason why sending a mail to a recipient would fail, show "The recipient cannot be verified. Please check all recipients of this message to verify they are valid."
    Use the old transport based spamassassin system instead of the new acl style one.
    Discard email for users who have exceeded their quota rather than keeping it in the queue.
     
    #13 bradyb, Jun 14, 2007
    Last edited: Jun 14, 2007
  14. bradyb

    bradyb Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Someone.. Anyone..

    Please Help.. None of my clients on my server are receiving mail but they can send. Only thing I can think of is if the updates last night changed anything.... Please someone, i am desperate.. I see all the mail in mail queue manager...
     
  15. bradyb

    bradyb Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Mail not coming in but sitting in Mail Queue Manager *Please Help*

    Mail is not coming in but I see them in Mail Queue Manager. This started last night. Please Help.. None of my clients on my server are receiving mail but they can send. Only thing I can think of is if the updates last night changed anything.... Please someone, i am desperate.. I see all the mail in mail queue manager... Any help is appreciated... And thanks ahead of time

    WHM 11.1.0 cPanel 11.2.1-C11635
    FEDORA 3 i686 - WHM X v3.1.0

    Server Configuration >> Update Config

    Config:
    Cpanel: Manual and Current

    Package Updates: Automatic

    Security Package Updates: Automatic

    All services are up

    imap up
    cpsrvd up
    pop up
    syslogd up
    eximstats up
    exim (exim-4.66-3_cpanel_smtpctl_av_rewrite_mm2_mmmtrap_exiscan_md 5pass) up
    ftpd up
    named (9.2.5) up
    spamd up
    mysql (4.1.22-standard) up
    exim-587 up
    httpd (1.3.37 (Unix)) up
    Server Load 0.34 (4 cpus)
    Memory Used 9 %
    Swap Used 0.00 %
    Disk /dev/sda6 (/tmp) 2 %
    Disk /dev/sda7 (/home) 22 %
    Disk /dev/sda1 (/) 75 %
    Disk /dev/sda2 (/usr) 40 %
    Disk /dev/sda3 (/var) 39 %


    Exim Configuration Editor


    Main >> Service Configuration >> Exim Configuration Editor

    Standard Options
    Always set the "Sender:" header when the sender is changed from the actual sender. Unchecking this will stop "On behalf of" data in Microsoft(R) Outlook, but may limit your ability to track abuse of the mail system.
    CHECKED: Verify the existence of email senders.
    CHECKED: Use callouts to verify the existence of email senders.
    Instead of showing the reason why sending a mail to a recipient would fail, show "The recipient cannot be verified. Please check all recipients of this message to verify they are valid."
    Use the old transport based spamassassin system instead of the new acl style one.
    Discard email for users who have exceeded their quota rather than keeping it in the queue.
     
  16. directfiesta

    directfiesta Member

    Joined:
    Apr 30, 2003
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    had that problem this morning ...

    restart exim solved it ...

    hope it does for you.
     
  17. johndoe

    johndoe Active Member

    Joined:
    May 26, 2002
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Hello forum members,
    I this same problem. Restarting exim did not solve the issue. I'll be watching this thread to see if anyone knows if anything unusual is going on after the latest update.
     
  18. SnakeO

    SnakeO Member

    Joined:
    Jan 10, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Cannot receieve new emails

    Hello,

    Our current email situation:

    1. We can send emails OK
    2. We can log into POP3 OK
    3. We can view existing messages in POP3 OK

    We CANNOT receive new emails. I tried sending an email to one of my accounts (jake@hybridstudio.com) from an outside account (jakechapa@gmail.com) and it did not go through, nor did I get a bounceback error on the gmail account.

    We first noticed this error this morning.

    Thanks
    -Jake
     
  19. bradyb

    bradyb Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    I had my colo guys fix it.. i think they reinstalled mail server but will let you know soon..
     
  20. adamint

    adamint Member

    Joined:
    Nov 28, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    I am still in the very early stages of investigating but I appear to be having a similar issue.

    WHM 11.1.0 cPanel 11.4.12-C13986

    Anyone got any ideas/solutions yet?


    Thanks

    Adam

    edit
    Just an update on this. My servers (i have 2 showing similar symptoms) are receiving email. they are just sitting in the queue. i try to redeliver but they dont work. I assume its because of retry times looking at the logs

    when i receive an email this is put into the logs

    2007-06-14 20:32:58 1Hyv3y-0000Ka-1m failed to read delivery status for XXXXXXXXX from delivery subprocess
    2007-06-14 20:32:58 1Hyv3y-0000Ka-1m appendfile transport process returned non-zero status 0x000b: terminated by signal 11
    2007-06-14 20:32:58 1Hyv3y-0000Ka-1m == XXXXXXXXX R=virtual_user T=virtual_userdelivery defer (-1)
    2007-06-14 20:32:58 1Hyv3y-0000Ka-1m Frozen

    my last email as at 4:32 this morning. no more since then. and I didnt get my daily upcp email.

    hope this helps someone.

    Cheers

    Adam
     
    #20 adamint, Jun 14, 2007
    Last edited: Jun 14, 2007
Loading...

Share This Page