The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim "malformed address" error - help needed

Discussion in 'General Discussion' started by mydomain, Apr 1, 2005.

  1. mydomain

    mydomain Well-Known Member

    Joined:
    Aug 10, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    One of our customers was getting mail from an external website sent to it just fine up until two days ago. Now, all mail into our server from this site is being rejected.

    I have checked the exim_mainlog and located the relevent entries which appear to indicate the Exim ACL does not like the header:

    2005-04-01 09:34:56 1DHHcE-0002N8-9w H=(xxxxxx.com) [66.xx.xxx.xx] F=<anonymous@xxxxxx.com> rejected after DATA: syntax error in 'From:' header when scanning for sender: malformed address: _this_xxxxx_email.com may not follow do_NOT_reply@to in "do_NOT_reply@to_this_xxxxx_xxxxx.com"

    Is there anything we can do on the exim configuration file to allow the mail through for this sender domain - can we bypass the ACL for it somehow, or what else can be done to resolve the issue - any help is greatly appreciated as the customer is unhappy that the mail gets through to their Hotmail and Yahoo accounts but rejected on our mailserver.

    TIA
    Mike
     
  2. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    I had experienced similar issues while i was on a server with Courier+sqwebmail ... Mails to certain remote domains were getting rejected with the same error. By any chance is the remote MTA courier? I do not remeber exactly but this was with Courier 0.28 ...

    Aaah i dug up and found the exact thing. Courier was messing up while sending and the same and was like this:

    MAIL FROM:<sender@senderdomain.com> SIZE=11729

    Which bounced back to me with:
    <<< 501 <sender@senderdomain.com> SIZE=11729: malformed address: SIZE=11729
    may not follow sender@senderdomain.com

    Size should not follow mail from ... and at that time the only suggestion from Courier MTA list was *Upgrade* and Oh Boy, upgrading Courier was no joy.... And i know how customers feel when they benchamrk any service against a spammers paradise ... Does Hotmail and Yahoo ever refuse anything :)
     
    #2 anup123, Apr 1, 2005
    Last edited: Apr 1, 2005
  3. mydomain

    mydomain Well-Known Member

    Joined:
    Aug 10, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Funny you say that as we told them the same thing regarding Hotmail and Yahoo - you hit the nail on the head there.

    Its quite a large and well known site sending the mail (wont name them in here) and it appears they are using QMAIL MTA from the mail headers received. They must have changed something as it was working up to 2 days ago.

    Not sure what we can do on this as I dont want to comment out verify header_sender in the exim ACL - not a good idea would you agree.
     
  4. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    897
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    This Planet
    If that's so (mails not oming after they have done somethig), try getting to the Admin of the service provider (and not the domain unless they are also the service provider themselves) and tell them that their MTA is messing up sending mails... it can be painful but the solution can be permanenet. We had a situation where Courier Would not send message to few Bif Government Sites with RFC 1035 errors ... we got in touch with them, exchanged the mail headers and messages, and finally they fixed the MX record at their end ... but it took me quite a bit of time to convince them that their MX record is in defiance of RFC 1035...

    Not too comfortable on commenting out header check ... but temporarily you could try that out if it does not break any other thing ... and does not lead to more spam flowing in ... just as i said no harm in trying if that temporarily could resolve things for your *unhappy* customer. Perhaps Chirpy would be best to guide on Exim issues...

    Anup
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Yup, that particular error is actually saying the the text on the email header:

    From:

    Line is not in an RFC compliant format. Only the sender can fix the application writing invalid email headers.

    Oh, and I would not disable sender checking just for that myself. In fact, I'm not sure that even if you did it would be allowed through by exim.

    Adding a bit more: the error comes at the DATA stage which is after ACL processing, so I doubt any ACL modification would allow it through - could be wrong.
     
    #5 chirpy, Apr 1, 2005
    Last edited: Apr 1, 2005
  6. mydomain

    mydomain Well-Known Member

    Joined:
    Aug 10, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Yes i agree with you Chirpy.

    We have contacted the sender and will see how it goes from there. Thanks for taking the time to respond to the thread guys.

    Many thanks,
    Mike
     
  7. northtrex

    northtrex Active Member

    Joined:
    Feb 26, 2005
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    This error could occur because the domain is not present in /etc/localdomains file. Please, confirm that the domain is present there and after, don't forget to restart CPOP and EXIM services.

    Hope it could help.
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    No, it's not, it's an email addressing problem. There's also no need to restart exim if you change /etc/localdomains and never any need to restart cppop which is unrelated.
     
  9. mydomain

    mydomain Well-Known Member

    Joined:
    Aug 10, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    No its nothing to do with that at all, the problem was the malformed headers in the mail being sent from the external address - they have fixed it at their end, the mails being sent are formatted correctly now and the issue is resolved.
     
Loading...

Share This Page