Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

exim / mysql server load **urgent**

Discussion in 'General Discussion' started by Zion Ahead, Nov 27, 2006.

  1. Zion Ahead

    Zion Ahead Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    166
    How do I trace what user is causing mysql to skyrocket the server load? I'm using cpanel (stable), phpsuexec, mysql 5, centos 4.4

    I have converted all accounts to :fail:

    What else could I do to optimize exim itself? Also, how do I apply RBL to exim? I know there are some info in cpanel, but I'd like various advices from people. I found some that did not even work anyway. Thank you.

    My configuration is below:


    my.cnf

    #DO NOT MODIFY THE FOLLOWING COMMENTED LINES!
    #Created with ELS from www.servermonkeys.com
    #els-build=5.0
    [mysqld]
    datadir=/var/lib/mysql
    skip-locking
    skip-innodb
    #skip-networking
    safe-show-database
    query_cache_limit=1M
    query_cache_size=128M ## 32MB for every 1GB of RAM
    query_cache_type=1
    max_user_connections=200
    max_connections=500
    interactive_timeout=10
    wait_timeout=20
    connect_timeout=20
    thread_cache_size=128
    key_buffer=512M ## 128MB for every 1GB of RAM
    join_buffer=1M
    max_connect_errors=20
    max_allowed_packet=16M
    table_cache=1024
    record_buffer=1M
    sort_buffer_size=4M ## 1MB for every 1GB of RAM
    read_buffer_size=4M ## 1MB for every 1GB of RAM
    read_rnd_buffer_size=4M ## 1MB for every 1GB of RAM
    thread_concurrency=8 ## Number of CPUs x 2
    myisam_sort_buffer_size=64M
    server-id=1
    log_slow_queries=/var/log/mysql-slow-queries.log
    long_query_time=2
    collation-server=latin1_general_ci

    [mysql.server]
    user=mysql
    old-passwords = 1

    [safe_mysqld]
    err-log=/var/log/mysqld.log
    pid-file=/var/lib/mysql/mysql.pid
    open_files_limit=8192

    [mysqldump]
    quick
    max_allowed_packet=16M

    [mysql]
    no-auto-rehash
    #safe-updates

    [isamchk]
    key_buffer=64M
    sort_buffer=64M
    read_buffer=16M
    write_buffer=16M

    [myisamchk]
    key_buffer=64M
    sort_buffer=64M
    read_buffer=16M
    write_buffer=16M

    [mysqlhotcopy]
    interactive-timeout

    exim.conf
    (see attached)

    I'm using MySQL 5 also. I have box trapper disabled, spam assassin enabled, mailman enabled.

    is this recommended?

    http://www.rvskin.com/index.php?page=public/antispam#1

    exim stats is the one that appears most in mytop too...it seems to be the cause of the server load spikes.
     

    Attached Files:

    • 1.gif
      1.gif
      File size:
      5.8 KB
      Views:
      28
    • 2.gif
      2.gif
      File size:
      6.5 KB
      Views:
      16
    • 3.gif
      3.gif
      File size:
      6.1 KB
      Views:
      12
    • mysql.gif
      mysql.gif
      File size:
      9.8 KB
      Views:
      26
    • exim.txt
      File size:
      32.7 KB
      Views:
      40
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice