The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim, Nobody, bounced emails.

Discussion in 'E-mail Discussions' started by Adrnalnrsh, May 16, 2005.

  1. Adrnalnrsh

    Adrnalnrsh Well-Known Member

    Joined:
    Apr 6, 2005
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    AZ
    How can I prevent bounced emails from just being sent to Nobody and sitting in the message queue? I would prefer that the emails be bounced back to the domain that it was relayed from. Like some users of a forum that I host setup accounts a while back and the emails are non existing, I would like that forum admin to receive the notifications, not me. However I see that the undeliverable emails are just sitting in my message queue, no notification to the domain owner.
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
  3. Adrnalnrsh

    Adrnalnrsh Well-Known Member

    Joined:
    Apr 6, 2005
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    AZ

    Ok, I did both of the above and still having the issue.

    I cannot run Phpsuexec, and I host a lot of forums, so sending mail as nobody needs to be on, correct?
     
  4. Adrnalnrsh

    Adrnalnrsh Well-Known Member

    Joined:
    Apr 6, 2005
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    AZ
    Ok, update. I disabled the sending mail as nobody option in tweak settings just to see if it would help. And of course it worked and mail is returned to sender. I was also worried if it would stop mail from being sent from some of my forums, and the mail is being delivered!
     
  5. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Yes, you can activate Phpsuexe, but you'll need to change the permission on every single Php file to 755. In addition, Php and other files must be owned by the user, otherwise they won't work. In addition, you need to find good ACLs and RBLs rules for your Exim, to stop dictionary attack, minimize spam, and keep your email server running smoothly.

    That's one of the best ways to stop "nobody" from sending out email.

    Good luck :)
     
  6. Adrnalnrsh

    Adrnalnrsh Well-Known Member

    Joined:
    Apr 6, 2005
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    AZ
Loading...

Share This Page