The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim not updating even though it says it is

Discussion in 'General Discussion' started by ramprage, Apr 10, 2003.

  1. ramprage

    ramprage Well-Known Member

    Joined:
    Jul 21, 2002
    Messages:
    667
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Canada
    Server Info:

    WHM 6.2.0
    Cpanel 6.4.0-S3
    RedHat 7.2


    Exim not updating even though it says it is.....

    exim is not up to date (Thu Feb 13 22:44:01 2003)
    Retrieving http://updates.cpanel.net/pub/sysup//7.2/exim/exim-3.36-121_cpanel_stmpcontrol_antivirus.i386.rpm
    Preparing... ##################################################
    exim #################################################proftpd is up to date (Thu Feb 13 22:44:01 2003)



    I run the Update Server Software in WHM and it tries to update Exim every time.... unsuccessfully I imagine.

    Where is this RPM stored and why wouldn't it be upgrading?
     
  2. ramprage

    ramprage Well-Known Member

    Joined:
    Jul 21, 2002
    Messages:
    667
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Canada
    Ok I downloaded the RPM manully and tried running

    rpm -Fvh exim*.rpm


    It then says

    "root@tower1 [~/download]# rpm -Fvh exim*.rpm
    error: failed dependencies:
    libsafe.so.1.3 is needed by exim-3.36-121_cpanel_stmpcontrol_antivirus
    "

    I check my libsafe and it says I have version 2!
    I searched RPM find and downloaded libsafe1.3
    Then when I try to install it I get this -

    root@tower1 [~/download]# rpm -i libsafe*.rpm
    package libsafe-2.0-16 (which is newer than libsafe-1.3-pre) is already installed


    WTF - Why doesn't Exim work with the newer version of Libsafe?
     
  3. ramprage

    ramprage Well-Known Member

    Joined:
    Jul 21, 2002
    Messages:
    667
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Canada
    Bump

    Why will this not upgrade?
    Is anyone else using LibSafe 2.016 and the latest version of Exim?
     
  4. ramprage

    ramprage Well-Known Member

    Joined:
    Jul 21, 2002
    Messages:
    667
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Canada
    Bump
     
  5. sqsisa

    sqsisa Well-Known Member

    Joined:
    Apr 8, 2003
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Bay Area, CA
    I think I have a way around this. But my info on it is at home. I will cherck it when I leave work and post something. I think I had the same problem a little while ago.
     
  6. sqsisa

    sqsisa Well-Known Member

    Joined:
    Apr 8, 2003
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Bay Area, CA
    Ok, this is the error that I got:
    > exim is not up to date (Wed Dec 31 19:00:00 1969)
    > Retrieving
    > http://updates.cpanel.net/pub/sysup//7.3/exim/exim-3.36-121_cpanel_stmpcontr
    > ol_antivirus.i386.rpm
    > Preparing...
    > ##################################################
    > file /etc/exim.pl from install of
    > exim-3.36-121_cpanel_stmpcontrol_antivirus
    > conflicts with file from package cpanel5-rh73-1.0-1.swsoft
    > file /etc/localdomains from install of
    > exim-3.36-121_cpanel_stmpcontrol_antivirus conflicts with file from
    > package
    > cpanel5-rh73-1.0-1.swsoft


    And this how I forced it. I'm not sure this will help you. It doesn't look like the same issue...........

    wget http://updates.cpanel.net/pub/sysup//7.3/exim/exim-3.36-121_cpanel_stmpcontrol_antivirus.i386.rpm
    rpm -ivh --force exim-3.36-121_cpanel_stmpcontrol_antivirus.i386.rpm
     
    #6 sqsisa, Apr 16, 2003
    Last edited: Apr 16, 2003
Loading...

Share This Page