Exim: Not using .forward files?

tbenoit

Member
Apr 15, 2003
5
0
151
Recently picked up another cPanel server.

I have a .forward in /root pointing to a valid email address on another server ([email protected]). I can manually send email to that address from this new server.

However, when I just send mail to "root", it appears as though exim is ignoring the existence of the .forward file. I tried this with another user on the system and received the same failure.


The .forward files on other servers work as expected.


OS: Red Hat Enterprise Linux v3 (latest Kernel).
cPanel: 8.8.0-S74


exim_mainlog log entries pertaining to a sample message on the new server (domain modified):

2004-02-15 16:26:42 1AsUio-0007VS-Pu <= [email protected] U=root P=local S=546
2004-02-15 16:26:42 1AsUio-0007VS-Pu remote host address is the local host: newserver.mydomain.com
2004-02-15 16:26:42 1AsUio-0007VS-Pu == [email protected] R=lookuphost defer (-1): remote host address is the local host
2004-02-15 16:26:42 1AsUio-0007VS-Pu ** [email protected]: retry timeout exceeded
2004-02-15 16:26:42 1AsUio-0007VU-Qo <= <> R=1AsUio-0007VS-Pu U=mailnull P=local S=1460
2004-02-15 16:26:42 1AsUio-0007VS-Pu Completed
2004-02-15 16:26:42 1AsUio-0007VU-Qo remote host address is the local host: newserver.mydomain.com
2004-02-15 16:26:42 1AsUio-0007VU-Qo == [email protected] R=lookuphost defer (-1): remote host address is the local host
2004-02-15 16:26:42 1AsUio-0007VU-Qo ** [email protected]: retry timeout exceeded
2004-02-15 16:26:42 1AsUio-0007VU-Qo [email protected]: error ignored
2004-02-15 16:26:42 1AsUio-0007VU-Qo Completed

exim_mainlog log entries pertaining to a sample message on the old server (domain modified):

2004-02-15 17:04:52 1AsVJk-0006KX-C3 <= [email protected] U=root P=local S=544
2004-02-15 17:04:53 1AsVJk-0006Kf-Dv <= [email protected] U=cpaneluser P=local-bsmtp S=945 [email protected]
2004-02-15 17:04:53 1AsVJk-0006Kf-Dv => enduser <[email protected]> R=virtual_user T=virtual_userdelivery
2004-02-15 17:04:53 1AsVJk-0006Kf-Dv Completed
2004-02-15 17:04:53 1AsVJk-0006KX-C3 => enduser <[email protected]> R=virtual_sa_user T=virtual_sa_userdelivery
2004-02-15 17:04:53 1AsVJk-0006KX-C3 Completed

I "diff" the exim.conf files on newserver and oldserver, and they were the same (no differences).


Here is the "userforward:" stanza from exim.conf:

userforward:
#!!# filter renamed allow_filter
driver = redirect
allow_filter
check_ancestor
check_local_user
domains = ! lsearch;/etc/userdomains
no_expn
file = $home/.forward
file_transport = address_file
pipe_transport = address_pipe
reply_transport = address_reply
no_verify

Here is the file settings for the .forward file:

-rw-r--r-- 1 root root 24 Feb 15 16:08 .forward

This one has got me stumped. I've been on exim.org's site and searched this site as well. Nothing I read pops out as to why this would be happening and what to do to fix it.


Any assistance would be appreciated.
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
31
473
Go on, have a guess
This seems the relevant line to me:

remote host address is the local host: newserver.mydomain.com

I would guess that you may have mydomain.com in your /etc/localdomains or you haven't got newserver.mydomain.com in your /etc/localdomains?

Thinking about it, it would seem logical that the latter might be the problem?
 

tbenoit

Member
Apr 15, 2003
5
0
151
Well, newserver.mydomain.com was missing from its /etc/localdomains file.

Interesting.....

Thanks for helping me out. I appreciate it.