The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim on another port

Discussion in 'General Discussion' started by perlchild, Apr 22, 2003.

  1. perlchild

    perlchild Well-Known Member

    Joined:
    Sep 1, 2002
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    I'm taking care of a few cpanel servers for a client, and I noticed something....

    With 2 servers running 6.4-stable and one running 6.4-edge, if the machine reboots, or if chkservd is restarted for any reason, the exim-on-another-port usually dies, and will not restart unless I go into service manager, remove the "exim on another port" and add it again(I use port 587, the MSA port, worked great until about 6.2)

    Now until about a week ago, I thought I was hallucinating, but it's becoming quite obvious this is a hassle(the edge machine is a development box, and gets restarted quite a lot more than the other two(kernel testing, for one)

    Is there a fix for this "maybe this is a bug but maybe it's not" annoying situation?
     
  2. FWC

    FWC Well-Known Member

    Joined:
    May 13, 2002
    Messages:
    354
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Ontario, Canada
    Edit /etc/chkserv.d/exim-587. If there are several blank spaces at the beginning of the line, remove them. Back the command up to the beginning of the line. This solved this problem for me. If they aren't there, I'm not sure what to do.
     
  3. perlchild

    perlchild Well-Known Member

    Joined:
    Sep 1, 2002
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    issue solved!

    I'm sorry it took so long to confirm, but this worked for me too, and solved the issue, many many thanks!
     
  4. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    How does one get the service to start once they take all the spaces out? Restart exim?

    cPanel.net Support Ticket Number:
     
  5. FWC

    FWC Well-Known Member

    Joined:
    May 13, 2002
    Messages:
    354
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Ontario, Canada
    After you edit the file in /etc/chkserv.d/ restart the service from Service Manager in WHM. That will start it right up. Chkservd itself will also catch it being down in a few minutes once the file is fixed.
     
  6. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    This did not cut it for me. I try to telnet to port 26 and all I get is:

    C:\Documents and Settings\Jon>telnet mail.greenolivetree.net 26
    Connecting To mail.greenolivetree.net...Could not open connection to the host, on port 26: Connect failed

    I rechecked config.apf and port 26 is open. Any other thoughts?

    cPanel.net Support Ticket Number:
     
  7. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    I read this in another thread...

    I changed the port to 27 and when everything settled out, it was working on 27.

    Thanks!

    cPanel.net Support Ticket Number:
     
  8. FWC

    FWC Well-Known Member

    Joined:
    May 13, 2002
    Messages:
    354
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Ontario, Canada
    Yeah, some ISP's are blocking 26 now, too. I run Exim on a port in the thousands on one server because of my firewall at work. :)
     
Loading...

Share This Page