The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EXIM Outbound Mail

Discussion in 'E-mail Discussions' started by uisiscom, Apr 8, 2014.

  1. uisiscom

    uisiscom Member

    Joined:
    Jan 15, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Unable to configure EXIM to send an outbound SMTP relay to a remote mail server. Can someone provide assistance on how to configure EXIM in WHM to send outbound mail to a remote mail server?

    The failed configuration settings as follows:



    Code:
    login:
      driver = plaintext
      public_name = LOGIN
      server_prompts = "userID:: : userpassword::"
      server_set_id = $1
      server_condition = "${if pam{$1:$2}{1}{0}}"
    
    
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    
    remote_smtp_over_ssh:
    
    driver = smtp
    
    port = 2525
    
    hosts_require_auth = outbound.mailhop.org
    
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    
    send_to_gateway:
    
    driver = manualroute
    
    domains = !+local_domains
    
    transport = remote_smtp
    
    route_list = * outbound.mailhop.org
    
    
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    
    
    send_to_smart_host:
    driver = manualroute
    route_list = !+local_domains outbound.mailhop.org
    transport = remote_smtp
    
    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    See example of EXIM script below:
    
    
    internal_routing:
      driver = dnslookup
      domains = +all_local_domains
      transport = smtp_inbound
      no_more
    
    new_mailbox:
      driver = redirect
      domains = le.ac.uk:domain.ac.uk
      data = ${lookup ... in new directory...
    
    pause_mail:
      driver = redirect
      domains = le.ac.uk:domain.ac.uk
      condition = PAUSE_RCPT
      data = :defer:
      allow_defer
      no_verify
      no_more
    
    find_mailbox:
      driver = redirect
      domains = le.ac.uk:domain.ac.uk
      data = ${lookup ...
     
    #1 uisiscom, Apr 8, 2014
    Last edited by a moderator: Apr 8, 2014
  2. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
  3. uisiscom

    uisiscom Member

    Joined:
    Jan 15, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    The port number is found in EXIM under remote_smtp_over_ssh:

    driver = smtp

    port = 2525

    hosts_require_auth = outbound.mailhop.org
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  5. uisiscom

    uisiscom Member

    Joined:
    Jan 15, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    No, question is not resolved.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  7. uisiscom

    uisiscom Member

    Joined:
    Jan 15, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Error message from syntax check reads:

    2014-04-12 23:20:24 Exim configuration error:
    two server authenticators (courier_plain and plain) have the same public name (PLAIN)
     
    #7 uisiscom, Apr 13, 2014
    Last edited: Apr 13, 2014
  8. uisiscom

    uisiscom Member

    Joined:
    Jan 15, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Amended authenticators section in the exim.conf::


    plain:
    driver = plaintext
    public_name = PLAIN
    server_prompts = :
    server_set_id = $2
    server_condition = "${if pam{$2:$3}{1}{0}}"

    login:
    driver = plaintext
    public_name = LOGIN
    server_prompts = "userID:: : password::"
    server_set_id = $1
    server_condition = "${if pam{$1:$2}{1}{0}}"
     
    #8 uisiscom, Apr 13, 2014
    Last edited: Apr 13, 2014
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you elaborate if you are still experiencing an issue, and if so, what error message you receive? When you post that you have modified your settings, we can not be sure if that means you have resolved the issue.

    Thank you.
     
  10. uisiscom

    uisiscom Member

    Joined:
    Jan 15, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Thank answer is still not resolved. What EXIM authenticators block should we use to login to a remote SMTP site: outbound.mailhop.org

    login:
    driver = plaintext
    public_name = LOGIN
    server_prompts = "userID:: : password::"
    server_set_id = $1
    server_condition = "${if pam{$1:$2}{1}{0}}"
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You may need to consult with a system administrator or post to the Exim mailing list if the information in the thread referenced here is not helpful. Keep in mind that assistance with custom ACL rules falls outside the scope of cPanel support. So, while we can try to direct you to the best resource possible, we can't always provide you with the exact custom rules to implement.

    Thank you.
     
  12. uisiscom

    uisiscom Member

    Joined:
    Jan 15, 2008
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Can we use nano/pico to make custom ACL changes?

    EXIM Message Board:

    No they don't. You didn't show us the authenticator named "courier_plain", which has the public_name "PLAIN" - like
    the error message said.

    Perhaps you're not looking at the actual configuration file
    that exim has been told to use?
     
  13. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page