The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim outgoing mail throughput is slow

Discussion in 'E-mail Discussions' started by OliverH, Jul 5, 2005.

  1. OliverH

    OliverH Member

    Joined:
    Jun 6, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    On one particular server, a few thousand emails are sent out as part of a set on one day. We are finding that the throughput for the outbound email is fairly slow - we are not getting much more than around 10 emails per second out of the server. It is a P4 machine in a datacentre so neither processing speed nor bandwidth is the bottleneck, in fact the load average stays around 0.1 the whole time email is going out.

    I have altered the queue_run_max parameter in the Exim configuration to now be 50, yet I can't detect any signs that indicate exim is using more queue runners or connections. The whole run of emails ends up taking many hours.

    Has anyone else tweaked Exim for higher outbound throughput? Could it be due to any antivirus or spam scanning on outbound emails? I would have thought such things would cause the load on the machine to go up dramatically but I have doubts as the load is always very low.
     
  2. jmginer

    jmginer Well-Known Member

    Joined:
    Jul 26, 2006
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Benifato, Spain
Loading...

Share This Page