Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Exim overriding default dkim

Discussion in 'E-mail Discussions' started by iso99, Feb 5, 2017.

  1. iso99

    iso99 Well-Known Member

    Joined:
    Jan 5, 2011
    Messages:
    104
    Likes Received:
    7
    Trophy Points:
    68
    cPanel Access Level:
    Root Administrator
    Hi,

    I need to change the default DKIM keys in my "transport" section of exim config. I'm using a smarthost, so I have a custom "router" and "transport" options in my exim config file.

    I tried adding "dkim_selector = xxx" in my transport, but it does not change anything. I also tried adding the other dkim options like "dkim_private_key" etc., but what only happens is that the header includes 2 dkim signatures, one for the default one and another for my custom selector key.

    Transport section:

    Code:
    smarthost_transport:
        driver = smtp
        hosts_require_auth = xxx.server.com
        port = 587
        dkim_selector = xxx
        dkim_domain = $sender_address_domain
        dkim_private_key = "/var/cpanel/domain_keys/private/${dkim_domain}"
        dkim_canon = relaxed
    
    Sample output of doubled DKIM signatures
    Code:
    DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed;
       d=mydomain.net; s=default; h=Message-ID:Subject:To:From:Date:
       Content-Transfer-Encoding:Content-Type:MIME-Version:Sender:Reply-To:Cc:
       Content-ID:Content-Description:Resent-Date:Resent-From:Resent-Sender:
       Resent-To:Resent-Cc:Resent-Message-ID:In-Reply-To:References:List-Id:
       List-Help:List-Unsubscribe:List-Subscribe:List-Post:List-Owner:List-Archive;
        bh=SHr4+LUicKfmV1jR7Yw4Saqk9NOGg8YwL7zKWvfZyPE=; b=B53RnTaqkz+NLJZyLyosEOvHE
       gPwvapvwvvfe/dIOkerxjouzACidTNWiwxQotrDaWgF7eEcr4YH7EJk5W9CKJ82cRPN941GXFms0q
       oM8UaT+4kqOMHRx/pU7on/ID3mMxb+4yf5hKloFTBsYedXh1URKNcZRmneUYMgCQIdx89s6vIrBDK
       9J6QTzQfSmrCNNx+gTTIjxDCEl1n3ZTkmWZIbJl23I7HWpGCTwkICyl8FddUfLSVJHV6NjDkaoyww
       AsMAFFhiMi1q/+VpfMqJ80e8M+0UsEBV7wAL9Gmk++HKfoqfaPeI1fPMIygm3H+Qn7GmWhoVDfry4
       fn7+h6qTA==;
    DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed;
       d=mydomain.net; s=default; h=Message-ID:Subject:To:From:Date:
       Content-Transfer-Encoding:Content-Type:MIME-Version:Sender:Reply-To:Cc:
       Content-ID:Content-Description:Resent-Date:Resent-From:Resent-Sender:
       Resent-To:Resent-Cc:Resent-Message-ID:In-Reply-To:References:List-Id:
       List-Help:List-Unsubscribe:List-Subscribe:List-Post:List-Owner:List-Archive;
        bh=SHr4+LUicKfmV1jR7Yw4Saqk9NOGg8YwL7zKWvfZyPE=; b=zHjR1swBR5pezm2J8GIkfuWaO
       53MD+ojnHl+7z8asUZS5gm1UTWHa0QBtt8tnRXRhC6lMGXkArnxCbv9HLGYs1V5gmBGXyZZvX5gtN
       R7Z2RYNspGSj1jzKgPk2BDCdVL343PB7VCDMeCHHltvhllulrv0PMttSJ2lGGixlv6SY0egCvlspp
       LggXz8pjK7gkkfQklv5JHVkPnwlapfEfJjK6vu2fYN7EJLfAptMPXys6qIRbEf5gRXlCCzWDqSZEb
       iYv1kWIyn6L4COCjNKDGZ4jQRkJZsL+XP7kctiQMq+kwAa38D2nJ2kglqJGJMs3Ou5rFyYmS7q6M+
       hKOJisMJw==;
    
    I think it's conflicting with dkim_remote_smtp. When the router proceeds to my custom transport, it still processes dkim_remote_smtp.

    I tried adding no_more after my router, does nothing too.

    This has been asked before but there was no solution on this topic.

    Hoping to get some responses again now :)

    Thanks.
     
  2. iso99

    iso99 Well-Known Member

    Joined:
    Jan 5, 2011
    Messages:
    104
    Likes Received:
    7
    Trophy Points:
    68
    cPanel Access Level:
    Root Administrator
    Ok, sorry, nevermind. Apparently, it all works. My smarthost also has a DKIM of its own which is conflicting with dkim in my cPanel when it relays the message - thus, the double dkim signatures. I disabled it and it's now only sending 1, along with the proper dkim_selector. :)
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm happy to see you were able to address the issue. Thank you for updating us with the outcome.
     
Loading...

Share This Page