The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim port changing after update

Discussion in 'E-mail Discussions' started by brisctt, May 29, 2008.

  1. brisctt

    brisctt Member

    Joined:
    Nov 9, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    In the service manager I've set to run on another port....port 587. It works fine, but I'm finding that after the daily update it randomly changes back to the default port 26.

    Does anyone have an idea of what's going on?

    Thanks
     
  2. viraj

    viraj Well-Known Member

    Joined:
    Sep 28, 2006
    Messages:
    209
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi,

    Try changing the attributes of the exim configuration file [/etc/exim.conf] to read only bu using this command :

    chattr +aiu /etc/exim.conf
     
  3. brisctt

    brisctt Member

    Joined:
    Nov 9, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Thanks, I'll give it a try.
     
  4. nickp666

    nickp666 Well-Known Member

    Joined:
    Jan 28, 2005
    Messages:
    770
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    /dev/null
    No point in doing this, upcp will reset the permissions each time it runs, I would raise a ticket with cPanel
     
  5. dbakstad

    dbakstad Member

    Joined:
    Jun 22, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    send on port 587 problem

    I'm a newbie, so hopefully this is on topic. I have users that cannot send email from hotels, etc, and they have requested an alternate port 587. I've turned this on in Service Configuration/Service Manager, and it responds:

    Saved Changes to exim-587 (enabled)

    Restarting chkservd monitoring daemon
    Stopping chkservd: [ OK ] Starting chkservd: [ OK ]
    Service Changes Complete

    Then restarted exim.

    I've tried every type of setting I can think of in outlook. Authentication on with all options, auth off, no ssl, with ssl, and still cannot send using port 587. I've also tried port 2525 with same result. I have no problem sending with port 25. The error from Outlook 2003 is:

    Task 'myserver.com - Sending' reported error (0x80042109) : 'Outlook is unable to connect to your outgoing (SMTP) e-mail server. If you continue to receive this message, contact your server administrator or Internet service provider (ISP).'

    telnet myserver 25
    220-myserver.com ESMTP Exim 4.69 #1 Tue, 24 Jun 2008 08:02:29 -0400
    220-We do not authorize the use of this system to transport unsolicited,
    220 and/or bulk e-mail.

    telnet myserver 587
    Connecting To myserver.com...Could not open connection to the host, on port 587:
    Connect failed

    I'm running WHM 11.23.2 cPanel 11.23.3-R25623

    If anyone can give me a hint on how to proceed, it will be much appreciated.
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Sounds like port 587 is blocked by a firewall.
     
  7. dbakstad

    dbakstad Member

    Joined:
    Jun 22, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Apf

    Thanks a million. I think you are probably correct. When the server was first brought online, a consultant installed APF. That's probably the problem. I'll dig thru the APF docs and see if I can figure out the change.
     
  8. AlexV.

    AlexV. Well-Known Member

    Joined:
    Jun 15, 2006
    Messages:
    212
    Likes Received:
    1
    Trophy Points:
    16
    I'm unable to replicate this behavior. I set the exim port to a non standard one (ie 587), ran upcp with the force option subsequently a couple of times, restarted the exim daemon among the execution of other scripts. The value seems to prevail.

    Please provide us with the exact version of cPanel you are running in order to try to replicate this matter.

    Thank you in advance.
     
Loading...

Share This Page