The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Prob

Discussion in 'General Discussion' started by kris1351, Oct 3, 2005.

  1. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Ever since Thursday's update I get this message about every 5 minutes.

    exim-26 failed @ Mon Oct 3 09:17:05 2005. A restart was attempted automagicly.

    Anything you can do to fix Exim's normal breaks I have done, anyone had this happen? I can't get it to stop restarting which is causing all kinds of fun with mail queues.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That's odd. You could check /var/log/chkservd.log as it might indicate why it's restarting it. Also, make sure port 26 isn't blocked completely in your firewall ;) Does another daemon perhaps have port 26 bound?
     
  3. pubenemy

    pubenemy Member

    Joined:
    Jul 4, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Im getting the same thing Port 26 is open with my firewall and nothing else is bound to it that I can tell. After last cpanel update it started bout 60 emails nof of it restarting..
     
  4. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Nothing has changed on the server, it just started restarting every 9 minutes on last Thursday's update. I have gone as far to reset exim to defaults and go from there, but the process just continues to restart. And only on the 26 port, not the 25.
     
  5. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    [Tue Oct 4 09:18:49 2005] Service check ....clamd [+]...cpsrvd [+]...exim [+]...exim-26 [-Notifcation => support@wwm.net via EMAIL [level => 3]
    Restarting exim-26....
    ]...eximstats [+]...ftpd [+]...httpd [+]...imap [+]...mysql [+]...named [+]...pop [+]...postgresql [+]...spamd [+]...syslogd [+]...Done


    Just keeps doing that there.
     
  6. bamasbest

    bamasbest Well-Known Member

    Joined:
    Jan 10, 2004
    Messages:
    531
    Likes Received:
    0
    Trophy Points:
    16
    Perhaps a useless stab in the dark.

    whm - service manager

    Run another copy of exim on port . xxx
    Useful for providers that block port 25.

    It appears to me as if another copy is being executed. Could it be that the copy of exim on 25 is being updated and the copy of exim on xx is not?

    Chirpy is the eximinator and would probably know if this may be a possible prob.;)
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    It actually sounds more like a bug in the new chkservd monitoring system to me. I would suggest:

    1. Go back into WHM > Service Manager > and save the configuration again.

    2. Check that /etc/chkserv.d/exim-26 looks OK compared to /etc/chkserv.d/exim

    3. Try telnetting on the server yourself, first to port 25:

    telnet 127.0.0.1 25

    (quit to exit)

    And then do the same for port 26:

    telnet 127.0.0.1 26

    (quit to exit)

    You should get the same output from each session. Ultimately, you could disable the monitoring of exim-26 in Service Manager and it should stop messing with it.
     
  8. pubenemy

    pubenemy Member

    Joined:
    Jul 4, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    The /etc/chkserv.d/exim-26 on my server wasnt formatted correctly. Think its fixed now.
     
  9. pubenemy

    pubenemy Member

    Joined:
    Jul 4, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Spoke too soon...
     
  10. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    I disabled monitoring on Exim-26 for now, I can telnet into both even when the monitoring says it is down.
     
  11. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Might be worth a ticket with cPanel to have them check it since the changes in the monitor system are so new.
     
  12. cyanide

    cyanide Well-Known Member

    Joined:
    Aug 11, 2003
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Toronto, Canada
    You're not alone. I'm having this problem too. But, only on one of my servers.
    So far, I have run /scripts/upcp --force which seemed to work for about 24 hours, but now it's back. Checking into it further.
     
  13. webcs

    webcs Member

    Joined:
    Oct 28, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I am running into this this week too. Exim restarts at least 6 times a day seemingly for no reason. Albeit doesnt seem as bad a you guys, maybe I have way fewer users.

    But I have several servers and only one is doing this.
     
  14. moribund

    moribund Member

    Joined:
    Nov 2, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Do any of you know what conditions chkservd uses to determine if a service has stopped working? The entries in /etc/chkserv.d/* are in a funky format.

    Thanks,
    Dave
     
  15. freakysid

    freakysid Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    Me too - I'm getting these warnings every ten minutes.

    WHM 10.8.0 cPanel 10.8.1-R30
    RedHat 7.3 i686 - WHM X v3.1.0

    ticket: cPanel ID# 117689
     
    #15 freakysid, Nov 13, 2005
    Last edited: Nov 13, 2005
  16. NicG

    NicG Member

    Joined:
    Apr 7, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I have been getting exactly the same problem, have turned it off for now.

    Has anyone found a solution to this?
     
  17. cmb

    cmb Member

    Joined:
    Apr 3, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I know this thread is really old, but I'm having this problem as well. Exim crashing and restarting, sometimes every 10 minutes. About 80 times in the past 7 days.
     
  18. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    So, what's in the exim mainlog and/or paniclog when the exim processes stop?
     
Loading...

Share This Page