The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim problem again... Authentication + Exim3.35 + Woody

Discussion in 'General Discussion' started by exeq, Mar 3, 2004.

  1. exeq

    exeq Registered

    Mar 2, 2004
    Likes Received:
    Trophy Points:

    I have an error during an authentication process.
    I use Debian distro + recent cPanel version.
    It looks like there's a lot of mess in this connection
    I have stable packages installed, only...

    The point is:

    I cannot configure exim (ver3) to allow authentication.
    The file model that is used by cPanel to keep passwords
    does not allow me to manage. It stores passes in
    /etc/vmail/passwd.domain.tld and in shadow files...
    The problem is that I cannot pass the dynamically
    bilt paths to the exim.conf. There's no such a variable
    to determine the .domain.tld ending in the auth phase.

    To make it clear:

    driver = plaintext
    public_name = LOGIN
    server_prompts = "Username:: : Password::"
    server_condition = "${if crypteq{$2}{${extract{1}{:}{${lookup{$1}lsearch{/etc/vmail/shadow.$host}{$value}{*:*}}}}}{1}{0}}"
    server_set_id = $1

    As you can see I tried to pass $host variable with no result

    BTW. I tried some automatic scripts (from /scripts dir)
    like buildeximconf and patcheximconf with no result too.
    Errors occured...

    I am verry beginner in cPanel world and I would be grateful
    for help... For me, right now, it looks like a real mess.


Share This Page