The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Problem? DNS??

Discussion in 'Bind / DNS / Nameserver Issues' started by argus, Nov 22, 2005.

  1. argus

    argus Member

    Joined:
    Mar 25, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hey there,

    I have a Virtual dedicated server using WHM/CPanel. I have all but one client on a shared ip. The client on his own ip is having problems receiving emails from a specific domain. But - Isn't he using the same mailserver as the rest? On clients using the shared ip I can receive email from the problem domain, but emails sent to his IP the emails don't get past the problem domain mailserver.
    Any ideas what's causing this and am I right that the mailserver is shared?

    Thanks,

    -a
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    So far as the server is concerned there's only one mail server which listens on all the IP addresses on the server for inbound email and sends out email on the main IP address of the server.

    To track down problems, you really need to tail the exim mainlog to see where the problems might be when email is sent to that domain:

    tail -f /var/log/exim_mainlog

    (<ctrl>-c gets you out of the tail)

    If you see nothing in the logs regarding that domain when an email is sent to it, it's not getting to the server and the problem is most likely DNS related (i.e. their MX record is not setup correctly or pointing elsewhere).
     
  3. argus

    argus Member

    Joined:
    Mar 25, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the clarification and the information.

    -a
     
Loading...

Share This Page