The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim problem.

Discussion in 'General Discussion' started by billy79, Feb 8, 2006.

  1. billy79

    billy79 Active Member

    Joined:
    Dec 15, 2004
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    On one of my servers my client gets the following error message whenever he tries to send an email via SMTP:

    When I restart EXIM I get:
    If you guys have any ideas on what I should do so that my client can send email again I would greatly appreciate it.

    -Billy
     
  2. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Try executing scripts like :-
    /scripts/exim4 --force
    /scripts/mailperm

    Also try sending emails from the clients account from your end and if you are able to, then the problem lies at your customers end and not on the server. Also the services seems to be started OK as per your post.
     
  3. billy79

    billy79 Active Member

    Joined:
    Dec 15, 2004
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Thanks for the update those are some real good ideas. Yes Exim did seem to start okay, it was that it failed to shutdown Exim and Spamd that worried me....I found it odd at least.

    -Billy
     
  4. netkinetics

    netkinetics Well-Known Member

    Joined:
    May 14, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Home is Baltimore, MD - Currently in the Philippin
    check /tmp for unusual spamd activity (lots of spamd directories) .. I recommend you check exim_mainlog and exim_paniclog to see what user is getting brute forced and set their default delivery (for user not found) to fail instead of localuser.

    Also really recommend some sort of brute force detection.

    Spam Assassin could not fork due to being clobbered, which was stopping exim from working (forking) correctly. You may also want to adjust your spamd startup settings to allow for more idle children on higher mail traffic servers.

    HTH :)
     
Loading...

Share This Page