The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim problems..

Discussion in 'General Discussion' started by PPNSteve, Mar 17, 2003.

  1. PPNSteve

    PPNSteve Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Somewhere in Ilex Forest
    cPanel Access Level:
    Root Administrator
    Twitter:
    anyone else getting unroutable mail domain error messages?
    errors from exim (running 6.0.0 s109)
     
  2. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    Did you resolve this issue, if so how?
     
  3. Diatone

    Diatone Well-Known Member

    Joined:
    Aug 22, 2001
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    I'm getting this all of a sudden as well. Please let me know if you resolve this issue.

    Mine is

    This message was created automatically by mail delivery software (Exim).

    A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:

    bob@intergate.com
    SMTP error from remote mailer after RCPT TO:<bob@intergate.com>:
    host mailgate.trip.net [216.139.64.25]: 553 5.1.8 <bob@intergate.com>... Domain of sender address burstban@mustang.burstnine.com does not exist

    ------ This is a copy of the message, including all the headers. ------

    Return-path: <burstban@mustang.burstnine.com>
    Received: from burstban by mustang.burstnine.com with local (Exim 3.36 #1)
    id 19AxYk-00089e-00
    for bob@intergate.com; Wed, 30 Apr 2003 13:48:06 -0600
    To: bob@intergate.com
    From: support@burstband.net
    Subject: {BB-274} Help Desk Response
    Message-Id: <E19AxYk-00089e-00@mustang.burstnine.com>
    Date: Wed, 30 Apr 2003 13:48:06 -0600
     
  4. howard

    howard Well-Known Member

    Joined:
    Apr 20, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    the above error can usually be solved by adding a dns A record for the hostname mustang.burstnine.com as the nameservers for burstnine.com report that it doesn't have one at the time i am writing this as shown below

     
  5. PcGN|CLuBBeR

    PcGN|CLuBBeR Member
    PartnerNOC

    Joined:
    Apr 18, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Amsterdam
    Had the same problems for 3 weeks (!!!!!!!$%^$^!!!) finally after 3 weeks the support.... well they first thought it was also the DNS but if the DNS is set right and you're still having these problems then you need to edit a specific .conf file. I can't recall which one but if needed i can ask my Admin for this.

    The problem is that Exim rejects the mail without looking what or for who it is, so u get an error header straight back.

    What Exim apparently needs to know is for which domain it is and in that .conf file you have to add your domains in order to work properly. Now maybe im a special case or sumtin but if somebody got the same problem then PM me and i will get the info on which .conf u need to edit.
     
  6. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    Why dont you post you exim.conf, without all the comments, just the settings?
     
  7. PcGN|CLuBBeR

    PcGN|CLuBBeR Member
    PartnerNOC

    Joined:
    Apr 18, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Amsterdam
    Like stated above i don't know the specific config file! please read then comment on a normal way aight ?
     
  8. howard

    howard Well-Known Member

    Joined:
    Apr 20, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    well there is a number reason why exim could give a error, it would be helpful if we knew what the error was however this are the files which exim uses when delivering mail

    /etc/localdomains -> so it knows what domains it should be reciving mail for

    /etc/vfilters/domain -> any filters which have been defined for the domain in question

    /etc/valiases/domain -> any aliases/forwarding/etc (stuff for mailling lists is also used here)

    /etc/userdomains -> so that exim knows which domain maps to which user on the system (for quota and to change uid when saving into the users mailbox etc)

    /etc/passwd used to find out its directory where it save mail etc

    /etc/aliases for any globally defined aliases (such as postmaster)
     
  9. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    I was just asking you to post your exim.conf. If anyone has this working, exim with phpsuexec and no bounced msgs and no returns to nobody could you post your exim.conf?

    Yes, but i dont think the problem is in those other files. My DNS is just find so i suspect it may be just something missing from exim.conf.
     
    #9 sexy_guy, Apr 30, 2003
    Last edited: Apr 30, 2003
  10. howard

    howard Well-Known Member

    Joined:
    Apr 20, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
  11. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    Thanks for that, its really default. Is that what your really running?
     
  12. howard

    howard Well-Known Member

    Joined:
    Apr 20, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    it straight out of the rpm file

    four@echo:~/bin/cpanel/exim140$ ls
    ./ ../ etc/ exim-3.36-140_cpanel_stmpcontrol_antivirus.i386.rpm usr/
    four@echo:~/bin/cpanel/exim140$ cd etc
    four@echo:~/bin/cpanel/exim140/etc$ ls
    ./ aliases exim.conf eximrejects logrotate.d/ rc.d/ spammers vfilters/
    ../ antivirus.exim exim.pl localdomains pam.d/ secondarymx valiases/
    four@echo:~/bin/cpanel/exim140/etc$

    (it actually doesn't make any difference what ver the exim.conf is frm as it hasn't been changed all year)

    four@echo:~$ grep -i exim.conf cpanel.sums
    478038d4a665f52bc14202636df2f6a1 /home/four/bin/cpanel/exim62/etc/exim.conf
    478038d4a665f52bc14202636df2f6a1 /home/four/bin/cpanel/exim121/etc/exim.conf
    478038d4a665f52bc14202636df2f6a1 /home/four/bin/cpanel/exim51/etc/exim.conf
    478038d4a665f52bc14202636df2f6a1 /home/four/bin/cpanel/exim82/etc/exim.conf
    478038d4a665f52bc14202636df2f6a1 /home/four/bin/cpanel/exim101/etc/exim.conf
    478038d4a665f52bc14202636df2f6a1 /home/four/bin/cpanel/exim141/etc/exim.conf
    four@echo:~$

    and yes i know the exim141/140 dir are diff that was because i typoed in the dir name when i orignally created it
     
    #12 howard, Apr 30, 2003
    Last edited: Apr 30, 2003
  13. PcGN|CLuBBeR

    PcGN|CLuBBeR Member
    PartnerNOC

    Joined:
    Apr 18, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Amsterdam
    Yes but then again i don't know "how to" and "where to" i have to go to find my exim.conf. There's my admin for.
     
  14. howard

    howard Well-Known Member

    Joined:
    Apr 20, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    your exim.conf is in the /etc directory (or should be on any normal cpanel system)
     
Loading...

Share This Page