WildWayz

Well-Known Member
Aug 14, 2001
209
0
316
Hi ya,

Myself and other users have notice that sometimes we get a \"relaying denied\" error when emailing from their account.

Any reason for this? It was working before I left for work, now I get this error.

--James
 

WildWayz

Well-Known Member
Aug 14, 2001
209
0
316
yeah - done the tail part - same error as Outlook reports... Relaying Denied + user/comp name/ip etc

No setting has changed on the server unless cpanel done something in an update :/

James
 

WildWayz

Well-Known Member
Aug 14, 2001
209
0
316
ack - now it IS sending them without smtp auth turned on.

It varies - most times it is fine, but sometimes it isn\'t.

James
 

WildWayz

Well-Known Member
Aug 14, 2001
209
0
316
[quote:afbfa3d4d1][i:afbfa3d4d1]Originally posted by AlaskanWolf[/i:afbfa3d4d1]
u sure theres no high loads on the server when it tires to send email? do you have any max_ configurations setup? [/quote:afbfa3d4d1]

max_confurations?

Its a normal Cpanel installation where only things like anonymous FTP are turned off.

Server load nerver goes over 0.7 (unless CPanel is updating, but then that is at 3:00am).

--James
 

Deep8808

Member
Feb 12, 2002
14
0
301
Hi,
I am gettin the same problem here...... relaying denied.
have tried /scripts/fixrelayd. This solves the problem temporarily but the problem crops up again within 24 hours.
Is there a permanant fix to this problem.... and why does this happen anyway?
Please advice.
I heard this problem had happened before .... if so please redirect me to the older one. Searched for it... but canjnot find it.
In deperate need of advice,
Thank you
 

feanor

Well-Known Member
Aug 13, 2001
836
0
316
Unless your syslogging is not compatible with cpanel this shouldn't be happening.... your syslogd.conf is recording pop3 activity to /var/log/maillog , right?
And even beyond people getting allowed for relay after logging in, if you force them to use the pop3 logins and passwords in SMTP authentication, which every popular email client supports, then you should never keep running through this cycle.
 

Deep8808

Member
Feb 12, 2002
14
0
301
Hi!
Thanks for that prompt response!
So using SMTP authentication should fix this problem?
The installation is a standard CPanel one..... and the problems started showing only in the last 2 days..
 

feanor

Well-Known Member
Aug 13, 2001
836
0
316
Yes, if they have that enabled, then they authenticate upon every connection to the smtp server- there is no reason to depend on the antirelaydaemon actually doing its job if you tell everybody to engage SMTP auth.
 

Deep8808

Member
Feb 12, 2002
14
0
301
Hi,
ooops! I am sorry. I tried that but it still does not work!!?
However fixrelayd still produces a {temporary} fix.What does fixrelayd do..?
Sorry about me behaving pest... but its just that I am running out of ideas...
Please help...
DeepEnd
 

feanor

Well-Known Member
Aug 13, 2001
836
0
316
What still doesn't work?

Fixrelayd kills syslog and antirelayd and restarts them both, so that when users log in successfully via pop3 they are being added to the allow file to send through the server without SMTP authentication.
 

Deep8808

Member
Feb 12, 2002
14
0
301
Hi!

&So using SMTP authentication should fix this problem?
The installation is a standard CPanel one..... and the problems started showing only in the last 2 days.. &

SMTP authentication does not fix the problem....
 

feanor

Well-Known Member
Aug 13, 2001
836
0
316
What is in /var/log/exim_mainlog , when these people are being rejected to send through the server........
 

feanor

Well-Known Member
Aug 13, 2001
836
0
316
Is /etc/relayhosts even being built?
Any content in it?


R U sure your /etc/syslog.conf is intact?
 

acetate

Active Member
Aug 16, 2001
25
0
301
Have you tried just setting up another session of exim running on a different port (ie.. 2500)?

/usr/sbin/exim -bd -q1h -oX 2500

or in cases where the client is running Eudora, you have to setup SMTP authentication with the username as account%domain.com
not [email protected]

Derek
IntenseHost.com LLC.
http://www.intensehost.com
 

Deep8808

Member
Feb 12, 2002
14
0
301
Hi,
/etc/relayhosts is gettin built.... no probs with that...looks as it usually should.
I was thinkin the problem could be 'cos of high server loads. But that is not the case...server load is real low.
DeepEnd