Exim probs - relaying denied

feanor

Well-Known Member
Aug 13, 2001
836
0
316
Ahhhhhhhhhhhhhhh

Disable the required lookups in exim for now. (/etc/exim.conf)... search for &lookup& or &reverse& , comment out the lines that require a successful lookup on IPs.

This is becoming more of an issue, especially lately, though I haven't had to permanently disable this on any box- I would like to know what makes exim more inquisitive about reverse delegation actually being intact from time to time.

Weird and fairly troublesome.
Restart exim if you do decide to disable that for now (/etc/rc.d/init.d/exim restart & then /scripts/fixrelayd, just in case)
 

WeMasterz5

Well-Known Member
Feb 24, 2003
361
0
166
Miami
ok...this is an old one... I kinda lost with the last post on here.

this is my tailed log


2004-01-02 10:32:56 1AcU6R-0000eb-Ju ** [email protected] R=lookuphost T=remote_smtp: SMTP error from remote mailer after RCPT TO:<[email protected]>: host mail.domain.com [xx.xxx.xxx.xx]: 550 5.7.1 <[email protected]>... Relaying denied. IP name lookup failed [xx.xxx.xxx.xx]
 

RaveKnights

Well-Known Member
Nov 5, 2003
81
0
156
Some Where Out There!
If I may add?

If you use more than one (1) email "webmail" program on your server, you are going to have problems.

If you allow IP addresses to relay than you need to un comment that inside the exim config file.

If you have major perm issues, than that would be related to accessing two different email progs. on the server.

Let me give example:

I logged into neoMail one day and Squirrel the next. after that I ran the fix mail inside of WHM out curiosity and that same email account came up with improper settings and WHM had fixed them. I allowed a whole day to pass by so that email would collect first before I did this. Remeber that if you want to test this theory out.

If I or my clients use only noemail or sqmail without one or the other than we never have any problems.

So I think the problem has to do with the programs setting different perms on files because neomail doesn't need the public_html directory so perms are more strict than sqmail.


This is what I can come up with after I analyzed the whole situation.
 

WeMasterz5

Well-Known Member
Feb 24, 2003
361
0
166
Miami
mm.... now this would be something for me to lookin to

Thanks