The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Processes Spawned

Discussion in 'General Discussion' started by mrcbrown, Sep 9, 2005.

  1. mrcbrown

    mrcbrown Well-Known Member

    Joined:
    Jun 5, 2003
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    I recently did the cPanel upgrade to release (WHM 10.6.0 cPanel 10.6.0-R158) - and the server was feeling sluggish on one of the installs, so in doing a ps, I found this:

    Code:
    mailnull 19052  0.0  0.1  6624 1852 ?        S    05:49   0:00 /usr/sbin/exim -bd -q60m
    mailnull 22201  0.0  0.3  7432 3712 ?        S    05:55   0:00  \_ /usr/sbin/exim -bd -q60m
    
    However mirror the second line about 15 times - each is taking up .3 of ram, and on ocasion 1-5% of CPU. I tried forcing a Exim re-install, compared my Exim.conf against another recently upgraded service which are not showing the issue, clear the mail-queue, and did the usual rkhunt with rkhunter & chkrootkit, things all came up good to go.

    Anyone have any insight as to why this could be happening? Logs show mail processing as normal, no strange segfaults, no errors about not being able to do XYZ - so I am at a loss at this point as to what is up - anyone have any ideas on how I can get Exim back in line and online running one of these now and again vs the steady 15?
     
  2. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    similar

    My box has recently started being very sluggish, with load averages in the 5 to 15 area, where normally it is 3-4. Doing a TOP I see:


    Code:
      PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME CPU COMMAND
     2635 mailnull  16   0   544  356   204 S    99.9  0.0   0:20   0 /usr/sbin/exim -bd -q60m
     4335 root      19   4  9336 9092  1736 S N  63.6  0.4   5:09   1 /usr/local/apache/bin/httpd -DSSL
    When I tail the exim log I'm not seeing any abnormal amounts of traffic or activity.

    Any pointers?

    - Scott
     
Loading...

Share This Page