May 11, 2004
14
0
151
Well im getting 2 main errors that are really screawing me over.

My proftpd is screawing me around and I cant restart it cause I get this error "proftpd dead but subsys locked" most of the stuff ive been reading online dont give me a direct answer on how to fix this.

Lastly my mail server is being lame also.
error "exim (exim-4.34-60_cpanel_stmpcontrol_antivirus_rewrite_mailman2_mailtrap_exiscan) failed"

When I try to restart it I get,

Jul 26 20:24:54 host exim: exim shutdown failed Jul 26 20:24:55 host exim: antirelayd shutdown succeeded Jul 26 20:24:55 host exim: spamd shutdown succeeded Jul 26 20:24:55 host exim: exim shutdown failed Jul 26 20:24:55 host exim: antirelayd shutdown failed Jul 26 20:24:55 host exim: spamd shutdown failed Jul 26 20:24:55 host exim: exim shutdown failed Jul 26 20:24:55 host exim: antirelayd shutdown failed Jul 26 20:24:55 host exim: spamd shutdown failed Jul 26 20:24:55 host exim: /usr/sbin/exim: error while loading shared libraries: libdb-3.3.so: cannot open shared object file: No such file or directory Jul 26 20:24:55 host exim: exim startup failed Jul 26 20:24:55 host exim: /usr/sbin/exim: error while loading shared libraries: libdb-3.3.so: cannot open shared object file: No such file or directory Jul 26 20:24:55 host exim: exim startup failed Jul 26 20:24:56 host exim: antirelayd startup succeeded Jul 26 20:24:56 host exim: spamd startup succeeded exim has failed, please contact the sysadmin.


Anyone have similar problems, or had and knows how to fix these problems?
 
May 11, 2004
14
0
151
For the exim part i've tried, /scripts/upcp --force

no ftp/email has been driving to the edge =|


EDIT

Would it be best to switch from Proftpd to Pure-ftpd?
Also should I just install exim from scratch by hand?
 
Last edited:
May 11, 2004
14
0
151
I tried running this.

cd /usr/src
wget -c http://updates.cpanel.net/exim-cpan...us_rewrite_mailman2_mailtrap_exiscan.i386.rpm
rpm -Uvh --force exim-4.34-60_cpanel_stmpcontrol_antivirus_rewrite_mailman2_mailtrap_exiscan.i386.rpm
rpm -Uvh --force


But its complaining about.

libdb-4.0.so



EDIT trying the following.


cd /usr/src
wget -c http://updates.cpanel.net/exim-cpan...rus_rewrite_mailman2_mailtrap_exiscan.src.rpm
rpm -Uvh --force exim-4.40-20_cpanel_stmpcontrol_antivirus_rewrite_mailman2_mailtrap_exiscan.src.rpm
rpm -Uvh --force



I got



[email protected] [/usr/src]# cd /usr/src
[email protected] [/usr/src]# wget -c http://updates.cpanel.net/exim-cpan...rus_rewrite_mailman2_mailtrap_exiscan.src.rpm
--15:12:03-- http://updates.cpanel.net/exim-cpan...rus_rewrite_mailman2_mailtrap_exiscan.src.rpm
=> `exim-4.40-20_cpanel_stmpcontrol_antivirus_rewrite_mailman2_mailtrap_exiscan.src.rpm'
Resolving updates.cpanel.net... failed: Host not found.
[email protected] [/usr/src]# rpm -Uvh --force exim-4.40-20_cpanel_stmpcontrol_antivirus_rewrite_mailman2_mailtrap_exiscan.src.rpm
error: open of exim-4.40-20_cpanel_stmpcontrol_antivirus_rewrite_mailman2_mailtrap_exiscan.src.rpm failed: No such file or directory
[email protected] [/usr/src]# rpm -Uvh --force
rpm: no packages given for install
[email protected] [/usr/src]#
 
Last edited:
May 11, 2004
14
0
151
Alright screw proftpd it sucks for me, im running pureftp and its pretty fast, thats all I can say.

As for exim I need to figure out how to install it or something then my server will be running perfectly.