Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Exim Questions

Discussion in 'E-mail Discussion' started by vkimura, Oct 30, 2015.

  1. vkimura

    vkimura Member

    Joined:
    Oct 2, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Burnaby, British Columbia, Canada
    I'm having a problem with the update for exim. I can restart the exim via WHM but I don't have access to exim commands like exigrep either.

    I ran these:
    root@ccd [/etc]# lsattr /etc/exim.conf
    -------A----- /etc/exim.conf
    root@ccd [/etc]# chattr -a /etc/exim.conf
    root@ccd [/etc]# /usr/local/cpanel/scripts/buildeximconf
    Configuration file has an invalid syntax. Please try the edit again.



    Error message from syntax check:
    2015-10-30 12:19:50 Exim configuration error in line 206 of /etc/exim.conf.buildtest.work.QSm7JJDK8lwvUhUI:
    main option "openssl_options" unknown

    -= BEGIN exim.conf chunk -=
    # are no local domains; not setting it at all causes the default value (the
    # setting of qualify_recipient) to be used.



    #!!# message_filter renamed system_filter
    message_body_visible = 5000


    # Specify a set of options to control the behavior of OpenSSL. The default is to
    # disable SSLv2 and SSLv3 due to weaknesses in these protocols.
    ==>openssl_options = +no_sslv2 +no_sslv3<==


    # If you want to accept mail addressed to your host's literal IP address, for
    -= END exim.conf chunk -=

    I tried to search why it's stating "openssl_options" is unknown when it's listed as an option in the main on the exim docs:
    14. Main configuration

    What could be wrong?

    Blessings<><,
    Victor
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,378
    Likes Received:
    1,857
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    Do you have any custom content added to the /etc/exim.conf.local file?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice