The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Queue Run Interval and deliver_queue_load_max

Discussion in 'General Discussion' started by santrix, Aug 22, 2011.

  1. santrix

    santrix Well-Known Member

    Joined:
    Nov 30, 2008
    Messages:
    223
    Likes Received:
    2
    Trophy Points:
    18
    I'm trying to improve our outgoing mail performance.

    I see the standard exim.conf generated by cpanel gives

    Code:
    begin retry
    *                      *           F,2h,15m; G,16h,1h,1.5; F,4d,8h
    To my understanding, the 15 minute retry never happen because exim is started with switch -q1h (meaning 1hr between queue runs)

    So, how can we change the way exim is started to allow the 15m retries?


    I also see this causing issues

    Code:
    deliver_queue_load_max = 3
    as our servers have 12+cpus, and the 5 minute linux load average is rarely under 5... Because this area of the exim.conf is not editable in WHM, the only way would be to edit manually (and thus risk the change being hosed by the next upcp)

    Any elegant way around this?

    Ta!
     
  2. tdens

    tdens Member

    Joined:
    Aug 18, 2011
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    You want to address this. With 12+ cpus if your load is that high you're probably IO bound. What does your disk setup look like?
     
  3. santrix

    santrix Well-Known Member

    Joined:
    Nov 30, 2008
    Messages:
    223
    Likes Received:
    2
    Trophy Points:
    18
    tdens... erm... not really. A load average of 1.00 on a 24 core machine doesn't really mean the same as it does on a machine with 2 cores - without haggling about storage bottlenecks.

    Can we keep to the Original questions here - primarily, to verify my first affirmation and answer my latter question! :P
     
  4. tdens

    tdens Member

    Joined:
    Aug 18, 2011
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Fair enough. Sorry for the distraction.
     
  5. Cedders

    Cedders Registered

    Joined:
    Aug 22, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Are changes to /etc/default/exim4 actually trashed on running upcp? If not, the QUEUEINTERVAL could be altered there.

    And I hope the information at Exim and greylisting | GreenNet is largely correct about deliver_queue_load_max. The suggestion is to enter the correct assignment in the first box of "WHM" > "Exim Configuration Editor" > "Advanced Mode". See also could not bind to address 0.0.0.0:443 [Archive] - DirectAdmin Forums for a suggested minimum value.

    I think we both want to get this sorted for the same reason :)
     
  6. DomineauX

    DomineauX Well-Known Member
    PartnerNOC

    Joined:
    Apr 12, 2003
    Messages:
    414
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I believe this is the precise purpose for the "Email delivery retry time" option in WHM Tweak Settings.
     
  7. DomineauX

    DomineauX Well-Known Member
    PartnerNOC

    Joined:
    Apr 12, 2003
    Messages:
    414
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
  8. santrix

    santrix Well-Known Member

    Joined:
    Nov 30, 2008
    Messages:
    223
    Likes Received:
    2
    Trophy Points:
    18
    Yep - it seems to totally replace the directive that is already in the advanced editor...

    #grep deliver_queue_load_max /etc/exim.conf
    deliver_queue_load_max = 6

    Note there is only one response - the original line entry for the default deliver_queue_load_max = 3 is completely hosed... I learned something today :)
     
  9. DomineauX

    DomineauX Well-Known Member
    PartnerNOC

    Joined:
    Apr 12, 2003
    Messages:
    414
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Glad to hear it works perfectly.
     
Loading...

Share This Page