The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim randomly failing, then working again

Discussion in 'General Discussion' started by flashsonix, Oct 17, 2004.

  1. flashsonix

    flashsonix Member

    Joined:
    Aug 30, 2004
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Hi!

    I've been having a serious problem with exim for 2 months now and it was impossible for me to fix it. Most of the time WHM service status shows that exim failed. Then all of a sudden it's working again for two days or more, just to fail again later.

    Any idea what could be causing this? Please help me out!

    I can post logfiles and stuff here if needed, just let me know which ones.

    Best regards!
     
    #1 flashsonix, Oct 17, 2004
    Last edited: Apr 20, 2007
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Have you tried upgrading Exim to the latest version:

    /scripts/exim4 --latest

    Might fix such problems. If you're already on the latest version, then do you have any relevant entries in /var/log/exim_paniclog (on aLinux server)?
     
  3. flashsonix

    flashsonix Member

    Joined:
    Aug 30, 2004
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1

    My server is running FreeBSD with WHM 9.9.0 cPanel 9.9.2-R8.

    I did /scripts/exim4 --latest and the output was...


    --------------------------------

    Exim Setup Script Version 15.0
    ---> Session started at: Mon, 18 Oct 2004 22:31:19 +0200
    ** No package has been installed or upgraded.
    ---> Session ended at: Mon, 18 Oct 2004 22:31:20 +0200 (consumed 00:00:00)
    Running post install scripts for exim....Done
    Waiting for exim to restart..............finished.

    root 20070 0.0 0.3 2296 1672 ?? S 10:31PM 0:00.00 antirelayd (perl)
    root 20083 8.2 4.0 19800 19168 ?? Ss 10:31PM 0:00.48 /usr/bin/spamd -d --allowed-ips=127.0.0.1 --pidfile=/var/run/spamd.pi
    d --max-children=5 (perl)
    root 20084 0.0 4.0 19800 19160 ?? S 10:31PM 0:00.00 spamd child (perl)
    root 20085 0.0 4.0 19800 19160 ?? S 10:31PM 0:00.00 spamd child (perl)
    root 20086 0.0 4.0 19800 19160 ?? S 10:31PM 0:00.00 spamd child (perl)
    root 20087 0.0 4.0 19800 19160 ?? S 10:31PM 0:00.00 spamd child (perl)
    root 20088 0.0 4.0 19800 19160 ?? S 10:31PM 0:00.00 spamd child (perl)

    exim has failed, please contact the sysadmin.


    -------------------------------


    /var/log/exim/paniclog =

    -------------------------------

    2004-08-26 20:34:37 socket bind() to port 25 for address (any IPv6) failed: Address already in use: daemon abandoned
    2004-08-26 20:34:37 socket bind() to port 465 for address (any IPv6) failed: Address already in use: daemon abandoned
    2004-08-27 18:08:16 1C0axt-000Bld-Tr User 0 set for local_delivery transport is on the never_users list
    2004-08-27 18:38:16 1C0axt-000Bld-Tr User 0 set for local_delivery transport is on the never_users list
    2004-08-27 19:08:16 1C0axt-000Bld-Tr User 0 set for local_delivery transport is on the never_users list
    2004-08-27 19:38:16 1C0axt-000Bld-Tr User 0 set for local_delivery transport is on the never_users list


    --------------------------------


    last line of /var/log/exim/mainlog =


    --------------------------------

    2004-10-13 03:17:03 1CHXkG-000FPN-UH SIGTERM received while reading local message


    --------------------------------

    Any idea what might be causing the trouble?

    Thanks for you help so far!
     
    #3 flashsonix, Oct 18, 2004
    Last edited: Apr 20, 2007
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I'd log a Trouble Ticket with cPanel to get that sorted out if I were you.
     
  5. flashsonix

    flashsonix Member

    Joined:
    Aug 30, 2004
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    I would, but...

    "If you are the customer of a hosting company or datacenter, you need to contact them for support. This form is for datacenters and directly-licensed cPanel customers only. "

    I am not directly licensed. My webhost is unmanaged and can't help me with this either.

    Do you think I should submit a trouble ticket anyway?
     
    #5 flashsonix, Oct 18, 2004
    Last edited: Apr 20, 2007
  6. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    You might ask Chirpy to help you out as his expertise and pricing are excellent. :)
     
Loading...

Share This Page