The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim refusing certain local addresses: lowest numbered MX record points to local host

Discussion in 'E-mail Discussions' started by marcz908, Sep 10, 2007.

  1. marcz908

    marcz908 Member

    Joined:
    Aug 31, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Exim is rejecting delivery to certain local address - not every one.

    Here is what my logs look like. (I changed the names)

    2007-09-10 12:26:43 lowest numbered MX record points to local host: refuseddomain1.com (while verifying <bob@refuseddomain1.com> from host web35712.mail.mud.yahoo.com [66.163.179.166])
    2007-09-10 12:26:43 H=web35712.mail.mud.yahoo.com [66.163.179.166] F=<exampleeddress@yahoo.com> temporarily rejected RCPT <bob@refuseddomain1.com>: lowest numbered MX record points to local host

    Also getting messages in /var/log/exim_mainlog that say "Frozen" at the end.

    I am running WHM 11.2.0 cPanel 11.11.0-R16908.

    Any suggestions?
     
  2. marcz908

    marcz908 Member

    Joined:
    Aug 31, 2007
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    It appears that the domain that isn't working isn't listed in /etc/localdomains. Sounds like a cpanel bug? Is there a fix? I don't know if I should edit this file by hand since cpanel works on it.
     
  3. bin_asc

    bin_asc Well-Known Member

    Joined:
    Jul 18, 2005
    Messages:
    280
    Likes Received:
    0
    Trophy Points:
    16
    If the domain has local mx, add it to the localdomains and remove it if it`s listed in remote domains. Also, i`d uncheck the option from WHM settings, the reference to adding remote mx and local mx when adding accounts.
     
  4. amaltemara

    amaltemara Member

    Joined:
    Dec 7, 2007
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    why is that?

    I was having the same problem, my mail being frozen, and not delivering. In my case, the mail was destined for a local domain, but only my subdomains were listed in /etc/localdomains, not my 2nd level domain.

    Why do you suggest unchecking the option to add remove mx and local mx when adding accounts? Isn't it necessary to add clients domains to the /etc/localdomains file in order to accept mail for them? I would think it would be necessary in the case that they have a local mailbox, and maybe in the case where they have set up an email forwarder?

    Any feedback on the issue is appreciated.

    Thanks,

    -Anthony Altemara
     
Loading...

Share This Page