Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Exim reject all mail

Discussion in 'E-mail Discussion' started by e-gor, Jan 16, 2006.

  1. e-gor

    e-gor Member

    Joined:
    Dec 9, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Kiev, Ukraine
    cPanel Access Level:
    Root Administrator
    Every mail for e-mails that exists on the server returns to the sender with:
    ... while talking to some_domain.:
    >>> DATA
    <<< 550 relay not permitted
    550 5.1.1 <test@some_domain>... User unknown
    <<< 503 valid RCPT command must precede DATA

    some_domain (of course there are other domain, that exist and setting up)

    What i should do to solve this? I run /scripts/eximup and /sripts/upcp --force but there are no result
     
  2. forlinuxsupport

    forlinuxsupport Well-Known Member
    PartnerNOC

    Joined:
    Dec 22, 2004
    Messages:
    386
    Likes Received:
    0
    Trophy Points:
    166
    cPanel Access Level:
    Root Administrator
    check
    drwxr-xr-x 2 root root 4096 Dec 13 23:45 /etc/vdomainaliases//

    has the correct permissions !!!
    mine has a habbit of loosing them.

    Try create a new accoutn on any domain, that has fixed it for me once or twice.

    also tail -f /var/log/exim_maillog and look for errrors
    exim_paniclog
    exim_rejectlog

    cheers
    Andy
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. e-gor

    e-gor Member

    Joined:
    Dec 9, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Kiev, Ukraine
    cPanel Access Level:
    Root Administrator
    looks like ok:
    drwxr-xr-x 2 root wheel 512 Jan 16 02:41 vdomainaliases

    (FreeBSD used)

    I have logs in the /var/log/exim and can't find exim_paniclog

    in the exim/rejectlog:
    2006-01-16 16:21:03 H=relay-1.another_domain [195.XXX.XXX.XXX] F=<egor@another_domain> rejected RCPT <test@some_domain>: relay not permitted

    in the exim/mainlog
    2006-01-16 16:20:32 H=(another_domain) [195.XXX.XXX.X] F=<egor@another_domain> rejected RCPT <test@some_domain>: relay not permitted
    2006-01-16 16:21:03 H=relay-1.another_domain [195.XXX.XXX.XXX] F=<egor@another_domain> rejected RCPT <test@some_domain>: relay not permitted
     
  4. forlinuxsupport

    forlinuxsupport Well-Known Member
    PartnerNOC

    Joined:
    Dec 22, 2004
    Messages:
    386
    Likes Received:
    0
    Trophy Points:
    166
    cPanel Access Level:
    Root Administrator
    Hi

    Make sure the FROM and TO addresses are actual email addresses !!

    I dont see .com or .co.uk on the ends of them

    If you dont come right, open a support request with cpanel and they can have a look,

    also check antirelayd is running.

    Regards
    Andy
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    The relay not permitted suggests that the domains are not listed in /etc/localdomains. Check that they're in there. If not, run:

    /scripts/updateuserdomains
    /scripts/mailperm

    Add any that are still missing.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. e-gor

    e-gor Member

    Joined:
    Dec 9, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Kiev, Ukraine
    cPanel Access Level:
    Root Administrator
    There arte actual addresses, i change IP and domains for forum :)

    running:

    mailnull 45032 0.0 0.5 5648 2704 ?? Ss 10:26AM 0:00.01 /usr/local/sbin/exim -bd -q30m (exim-4.60-0)
    mailnull 45035 0.0 0.5 5648 2652 ?? Ss 10:26AM 0:00.00 /usr/local/sbin/exim -tls-on-connect -bd -oX 465 (exim-4.60-0)
    root 45041 0.0 0.4 2484 1828 ?? S 10:26AM 0:00.00 antirelayd (perl5.6.2)
     
  7. e-gor

    e-gor Member

    Joined:
    Dec 9, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Kiev, Ukraine
    cPanel Access Level:
    Root Administrator
    Domains listed. But updateuserdomains return errors:

    # ./updateuserdomains
    == WORKAROUND ENABLED ==
    Serious Problem -- This should never happen!!
    The hostname (hosting_domain) is owned by the user wwwbron
    == WORKAROUND ENABLED ==


    wwwbron is resseler user used for new users registration, may be it incorrect? And i need create new user for the hosting_domain?
     
  8. e-gor

    e-gor Member

    Joined:
    Dec 9, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Kiev, Ukraine
    cPanel Access Level:
    Root Administrator
    The hostname was set, i should remove it from the resseler's account?
     
  9. e-gor

    e-gor Member

    Joined:
    Dec 9, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Kiev, Ukraine
    cPanel Access Level:
    Root Administrator
    It doesn't help (after removing domain updateuserdomains doesn't report any error, but mail still rejects) :( In addition when i open in browser hosting_domain i recieve cpanel error, that no site configured for this address :)
     
  10. e-gor

    e-gor Member

    Joined:
    Dec 9, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    Kiev, Ukraine
    cPanel Access Level:
    Root Administrator
    Solved with complete reinstall cpanel :)
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice