The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim restart error.

Discussion in 'General Discussion' started by Domenico, Jul 24, 2003.

  1. Domenico

    Domenico Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    362
    Likes Received:
    0
    Trophy Points:
    16
    Did you also noticed that the only way to restart Exim is in a SSH session -> /etc/init.d/exim restart

    Restarting through WHM will give you this error:

    2003-07-24 23:20:35 socket bind() to port 25 for address (any IPv4) failed: Address already in use: waiting before trying again
    2003-07-24 23:20:35 socket bind() to port 465 for address (any IPv4) failed: Address already in use: waiting before trying again

    cPanel.net Support Ticket Number:
     
  2. tAzMaNiAc

    tAzMaNiAc Well-Known Member

    Joined:
    Feb 16, 2003
    Messages:
    559
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sachse, TX
    Huh? I can do it in WHM as well. Works just fine.

    Are you asking a question or telling us?

    cPanel.net Support Ticket Number:
     
  3. Domenico

    Domenico Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    362
    Likes Received:
    0
    Trophy Points:
    16
    Ok, restart it through WHM and then do tail /var/log/exim_mainlog

    Maybe you get the same errors as we get. Exim does work after a restart in WHM but you get these errors with it.

    cPanel.net Support Ticket Number:
     
  4. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    I have noticed the same thing when using Exim Configuration Editor. Whenever it is used and the "Save" button clicked, Exim will restart with the exact same errors -- as seen in a tail. Thought it was a bug with just that feature, but appears it happens whenever Exim is restarted through WHM. Only way I found to stop the loop is to stop/start Exim in Shell.

    cPanel.net Support Ticket Number:
     
  5. Domenico

    Domenico Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    362
    Likes Received:
    0
    Trophy Points:
    16
    I hope Nick will fix this.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page