Exim retry times after being greylisted

sneader

Well-Known Member
Aug 21, 2003
1,195
65
178
La Crosse, WI
cPanel Access Level
Root Administrator
I sent an email via one of our cPanel servers, to a friend of mine using another provider. That provider deferred my email (450 error) due to "greylisting" which is fine. The problem I'm trying to sort out is why our cPanel server waited over 8 hours to try to deliver the message again (and it was immediately accepted, when it did)

On our cPanel server, the RETRYBLOCK is using defaults:

* * F,2h,15m; G,16h,1h,1.5; F,4d,8h

The only thing I could think of that would prevent another retry is the "deliver_queue_load_max" setting, but that is at 8, and MRTG graphs show that load never went above 4 during this time period.

Any other ideas on things to check?

- Scott
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,237
463
Hello,

Can you let us know the output from /var/log/exim_mainlog for that specific message? EX:

Code:
exigrep MSGID /var/log/exim_mainlog
Replace MSGID with the message ID, as found in the header of the email.

Thank you.
 

sneader

Well-Known Member
Aug 21, 2003
1,195
65
178
La Crosse, WI
cPanel Access Level
Root Administrator
Thanks for the assist! Delivery of this email is spread out over two logs, but I've included them both, below. I've redacted the following:

My email address / email account = [email protected]
Recipient (that is greylisting me) = [email protected]

Confusing things a little, this message was sent using GMail, but using a cPanel-based email account for SMTP, so that is why you see the email come in from mail-it0-f48.google.com.

Code:
# exigrep 1f51m0-002ALY-O4 /var/log/exim_mainlog.1.gz
2018-04-07 23:17:48 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1f51m0-002ALY-O4

+++ 1f51m0-002ALY-O4 has not completed +++
2018-04-07 23:17:48 1f51m0-002ALY-O4 <= [email protected] H=mail-it0-f48.google.com [209.85.214.48]:35427 P=esmtpsa X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no A=dovecot_plain:[email protected] S=4590 [email protected]l.com T="Re: Some Subject" for [email protected]
2018-04-07 23:17:48 1f51m0-002ALY-O4 Sender identification U=myuser D=mydomain.com [email protected]
2018-04-07 23:17:48 1f51m0-002ALY-O4 SMTP connection outbound 1523161068 1f51m0-002ALY-O4 mydomain.com [email protected]
2018-04-07 23:17:49 1f51m0-002ALY-O4 H=mx1.zmailcloud.com [34.192.224.172]: SMTP error from remote mail server after RCPT TO:<[email protected]ample.com>: 450 4.2.0 <[email protected]>: Recipient address rejected: Greylisted, see http://postgrey.schweikert.ch/help/example.com.html
2018-04-07 23:17:50 1f51m0-002ALY-O4 H=mx2.zmailcloud.com [35.168.78.194]: SMTP error from remote mail server after RCPT TO:<[email protected]>: 450 4.2.0 <[email protected]>: Recipient address rejected: Greylisted, see http://postgrey.schweikert.ch/help/example.com.html
2018-04-07 23:17:50 1f51m0-002ALY-O4 == [email protected] R=dkim_lookuphost T=dkim_remote_smtp defer (-44) H=mx3.zmailcloud.com [52.206.190.81]: SMTP error from remote mail server after RCPT TO:<[email protected]>: 450 4.2.0 <[email protected]>: Recipient address rejected: Greylisted, see http://postgrey.schweikert.ch/help/example.com.html
Code:
# exigrep 1f51m0-002ALY-O4 /var/log/exim_mainlog
2018-04-08 07:32:02 1f51m0-002ALY-O4 Sender identification U=myuser D=mydomain.com [email protected]
2018-04-08 07:32:02 1f51m0-002ALY-O4 => [email protected] R=dkim_lookuphost T=dkim_remote_smtp H=mx1.zmailcloud.com [34.192.224.172] X=TLSv1.2:ECDHE-RSA-AES256-GCM-SHA384:256 CV=yes C="250 2.0.0 Ok: queued as E0D4760487"
2018-04-08 07:32:02 1f51m0-002ALY-O4 Completed
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,237
463
Hello,

Can you browse to the "Mail" tab in "WHM >> Tweak Settings" and let us know what's configured for the "Email delivery retry time" option? The default is 15 minutes.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,237
463
Hello,

Could you open a support ticket so we can take a closer look at the affected system?

Thank you.