Exim return path/bounce address

Liam McArthur

Member
Jan 31, 2018
8
2
3
United Kingdom
cPanel Access Level
Root Administrator
I'm having problems setting the return-path/bounce address for my website. I think it seems to be an Exim related issue because everytime I set a header in PHP, it's just ignored. Because of this, I'm getting an awfully high spam score. Is anybody able to advise on the settings I can make to get this resolved?

For some reason it's automatically changing the return/bounce address to [email protected].
 
Last edited by a moderator:

Liam McArthur

Member
Jan 31, 2018
8
2
3
United Kingdom
cPanel Access Level
Root Administrator
Ah yes! I never thought about SMTP authentication. Okay, well I've found a plugin for our websites that will allow us to use SMTP auth instead, but after enabling this I was receiving 535 Incorrect authentication data - password command failed errors. I narrowed this down to an option in the Tweak Settings are of WHM: Restrict outgoing SMTP to root, exim, and mailman. When disabling this, the SMTP connects fine and successfully sends mail. My only worry is that this could cause spam issues on the server? Is there a method of allowing the website to send via SMTP without completely opening it to everybody?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,226
463
I narrowed this down to an option in the Tweak Settings are of WHM: Restrict outgoing SMTP to root, exim, and mailman. When disabling this, the SMTP connects fine and successfully sends mail. My only worry is that this could cause spam issues on the server? Is there a method of allowing the website to send via SMTP without completely opening it to everybody?
Hello,

The feature is not designed for modifications or whitelisting of additional users. I suggest using a third-party firewall management utility such as CSF instead:

ConfigServer Security & Firewall

There are options that allow you to restrict SMTP similar to the SMTP Restrictions option in WHM, but with exemptions.

Thank you.