Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

EXIM running on Port 1 ?

Discussion in 'General Discussion' started by hicom, Aug 14, 2004.

  1. hicom

    hicom Well-Known Member

    Joined:
    May 23, 2003
    Messages:
    282
    Likes Received:
    2
    Trophy Points:
    168
    Hi, I've EXIM 4.41 running with CLAMD EXISCAN.

    When I restarted EXIM just today, I noticed the following message:

    2004-08-14 17:41:06 exim 4.41 daemon started: pid=51012, no queue runs, listening for SMTPS on port 465 (IPv6 and IPv4)
    2004-08-14 17:41:06 exim 4.41 daemon started: pid=51015, no queue runs, listening for SMTP on port 1 (IPv6 and IPv4)


    I checked Port 1, and it is actually open for transmitting mail as well as port 110, 465.

    I tried to send bulk mail through it, but thank god it did not allow relay. However, I'm concerned why Port 1 is open.

    Is there an option to disable it in Exim ?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    22
    Trophy Points:
    463
    Location:
    Go on, have a guess
    That appears to be a very serious problem either with the 4.41 build, your /etc/init.d/exim file, or if you have it set to run on port 1 in WHM > Manage Services
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. hicom

    hicom Well-Known Member

    Joined:
    May 23, 2003
    Messages:
    282
    Likes Received:
    2
    Trophy Points:
    168
    I'm running on FreeBSD 4.10. Apparently, this seems to be a BUG somehow in cPanel , even thought in WHM I have NO check mark next to 'Enable Exim on Another Port'

    somehow cPanel is enabling Port 1 and somtimes Port 26.

    So I went to /scripts/restartsrv_exim

    and commented out the line:

    if ( my $otherport = &exim_other_port ) {
    # system("/usr/sbin/exim","-bd","-oX","$otherport");
    }


    Restarted, and port 1 was not enabled anymore.

    Here is my EXIM results before I made the change:

    mailnull 69561 0.0 0.3 5404 3316 ?? S 5:09AM 0:00.00 /usr/local/sbin/exim -q (exim-4.41-0)
    mailnull 69446 0.0 0.3 4912 2760 ?? Ss 5:09AM 0:00.00 /usr/sbin/exim -bd -oX 1 (exim-4.41-0)
    mailnull 69443 0.0 0.3 4912 2760 ?? Ss 5:09AM 0:00.00 /usr/sbin/exim -tls-on-connect -bd -oX 465 (exim-4.41-0)
    mailnull 69441 0.0 0.3 4912 2772 ?? Ss 5:09AM 0:00.00 /usr/sbin/exim -bd -q30m (exim-4.41-0)
    root 69459 0.0 0.2 2276 1744 ?? S 5:09AM 0:00.02 antirelayd (perl)


    This is the results after the change (notice no port 1 ):

    mailnull 69820 0.0 0.3 4912 2756 ?? S 5:13AM 0:00.01 /usr/sbin/sendmail -bS (exim-4.41-0)
    mailnull 69767 0.0 0.3 4912 2764 ?? Ss 5:13AM 0:00.00 /usr/sbin/exim -tls-on-connect -bd -oX 465 (exim-4.41-0)
    mailnull 69765 0.0 0.3 4912 2776 ?? Ss 5:13AM 0:00.00 /usr/sbin/exim -bd -q30m (exim-4.41-0)
    root 69781 0.0 0.2 2276 1740 ?? S 5:13AM 0:00.02 antirelayd (perl)
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice