The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EXIM Send Problem

Discussion in 'General Discussion' started by ggooden, Aug 31, 2004.

  1. ggooden

    ggooden Member

    Joined:
    Dec 9, 2002
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Pasadena, California, United States
    cPanel Access Level:
    Root Administrator
    Suddenly today, my CPANEL users cannot send mail OUT or receive mail in. If I send a test message IN, I get:

    > <mike@fullservicephoto.com>:
    > 69.89.72.149 does not like recipient.
    > Remote host said: 550-Verification failed for
    <michaeldardenelle@sbcglobal.net>
    > 550-unrouteable mail domain "sbcglobal.net"
    > 550 Sender verify failed
    > Giving up on 69.89.72.149.



    And if I try to "redeliver" a message in the mail queue, I get:

    Message 1C2EF9-0000Tm-PA is no longer frozen
    delivering 1C2EF9-0000Tm-PA
    LOG: MAIN PANIC
    failed to expand condition "${perl{checkusersa}{$local_part}{$received_protocol}}" for sa_localuser router: error in perl_startup code: Too many arguments for open at /etc/exim.pl line 538, near ""/var/cpanel/users/${trueowner}") "


    LOG: MAIN PANIC
    failed to expand condition "${perl{hasfilterfile}{$local_part}}" for central_user_filter router: Undefined subroutine &main::getusersdomain called at /etc/exim.pl line 45.

    LOG: MAIN PANIC
    failed to expand condition "${perl{checkspam}}" for lookuphost router: Undefined subroutine &main::getdomainowner called at /etc/exim.pl line 365.

    LOG: MAIN PANIC
    failed to expand condition "${perl{checkspam}}" for literal router: Undefined subroutine &main::getdomainowner called at /etc/exim.pl line 365.

    LOG: MAIN
    ** ggooden@annex.net <root@daedalus.annex.com> R=fail_remote_domains: unrouteable mail domain "annex.net"
    LOG: MAIN
    Frozen (delivery error message)



    So, I've tried rebuilding EXIM and running /scripts/upcp

    Any ideas about how to fix this? :)

    MUCH appreciated!

    Gregory
     
  2. bert

    bert Well-Known Member

    Joined:
    Aug 21, 2001
    Messages:
    602
    Likes Received:
    0
    Trophy Points:
    16
    Exim appears to be screwed up big time lately. Make sure you disable "Verify Senders" in the Exim configuration section of WHM. That should correct the problem for the time being.
     
  3. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Try

    chattr -i /etc/exim.pl
    /scripts/updatenow
    /scripts/exim4

     
  4. AbeFroman

    AbeFroman BANNED

    Joined:
    Feb 16, 2002
    Messages:
    654
    Likes Received:
    1
    Trophy Points:
    0
    That rediculous, do you not realize how important email is? Why are there so many bugs with cpanel and cppop/exim? What does it take to a get a bug free version of cpanel with mail? Does cpanel really not care if someone email/business is down for hours? just do a search on this forum and see how many email issue there are, or even for email servers that were working fine and then suddenly stopped working. Yahoo and hotmail have millions of email accounts and theirs are way more reliable than mail on a cpanel server, oh yeah, and its free.
     
  5. cPanelBilly

    cPanelBilly Guest

    This is caused by someone telling exim.pl that it cannot be edited then updating exim which needs that file edited and it cannot be. So what bdraco told him to do was allow the file to be edited and then update again. Thus fixing the issue that he created.
     
  6. cPanelBilly

    cPanelBilly Guest

    you should be fine to update. This will not effect FreeBSD.
     
  7. cPanelBilly

    cPanelBilly Guest

    only if you had previously chattr +i /etc/exim.pl
     
  8. isnoop

    isnoop Active Member

    Joined:
    Jun 13, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Having the same problem on a BSD machine here. Are you saying there is FreeBSD no fix for this yet, or that running upcp is just fine? If the former, what can FBSD users do to fix this?
     
  9. Ali

    Ali Well-Known Member

    Joined:
    Jul 12, 2003
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    I'm facing the same issue after cPanel's auto-update yesterday. Cannot send or receive emails!!! -- I've tried all suggestions on this thread and nothing seems to help.

    Anyone with a fix ?
     
  10. bman

    bman Well-Known Member

    Joined:
    Dec 28, 2003
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    up
    up
    up
    up
     
  11. hyperth

    hyperth Registered

    Joined:
    Mar 15, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    i believe that i have the same problem.

    failed to expand condition "${perl{checkspam}}" for literal router

    I can't send any emails from localhost from my shell.

    i run this cmd

    exim -v myemail@somewhere.gr < test.email

    and the error msg is:

    unrouteable mail domain

    any ideas?

    please
     
  12. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    You need to make sure that:

    1. nobody is not disabled from sending out email

    2. check out /etc/resolve.conf and see if the nameserver/IPs are correct.

    If that didn't solve your problem, send us an email note and we'll be more than happy to work with you and put this issue to rest. :)

    Thank you!
     
  13. Imago

    Imago Active Member

    Joined:
    Feb 21, 2004
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    I am having the same problem after the last security update. Exim send and receive do not work, sendmail too.

    Tried the proposed solutions to no awail.

    My clents are very happy to not receive anymore spam.

    But it is also true, that all forums are dead.
     
    #13 Imago, Nov 18, 2004
    Last edited: Nov 18, 2004
Loading...

Share This Page