Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Exim sending all email for user to /dev/null

Discussion in 'E-mail Discussion' started by jsteel, Oct 14, 2004.

  1. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Atlanta, GA
    Be forewarned. Apparently the following filter that a user of ours had in place for over a year is now causing problems after a recent upgrade to 9.9.2-R7:

    # Exim filter

    if error_message then finish endif

    if
    $h_X-Spam-Status: contains "yes"
    then
    save "/dev/null" 660
    endif


    The result of this was sending *ALL* email to /dev/null for the domain. It's most likely a result of the SpamAssassin 3 upgrade.
     
  2. pizzaman

    pizzaman Well-Known Member
    PartnerNOC

    Joined:
    Oct 1, 2003
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    156
    I have this on one of my customers as well,
    even on cPanel 9.9.8-C44. To fix it, I need to go to cPanel > Mail > Mail Filter
    and delete that rule.
     
  3. Marty

    Marty Well-Known Member

    Joined:
    Oct 10, 2001
    Messages:
    630
    Likes Received:
    1
    Trophy Points:
    318
    Change the filter from "contains" to "starts with" or "begins with" and it should work as expected.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice