EXIM sending mail to the wrong user!

gordita

Well-Known Member
Aug 14, 2001
113
0
316
It looks like since cpanel STABLE_90 any mail sent to a main user @ virtualdomain.com is being sent to the wrong user! For instance when I send to [email protected] the message get\'s sent to the main account for the reseller of their virtual domain (as setup in WHM)... does that make sense? I\'m tempted to revert to the /ect/exim.conf that is pre STABLE_90... does you know if that would cause more problems?
 

gordita

Well-Known Member
Aug 14, 2001
113
0
316
I just replaced my current exim.conf file with one from STABLE_83 and I still have the problem :(
 

gordita

Well-Known Member
Aug 14, 2001
113
0
316
Okay, I\'ve found out that it has nothing to do with the reseller, the mail get\'s bounced to my own email address regardless of the reseller the account is under. Why my address? I don\'t know. I\'ve searched /etc/exim.conf, valiases/, and domainalias configuration files and didn\'t see anything out of the ordinary. Anybody have any ideas?
 

gordita

Well-Known Member
Aug 14, 2001
113
0
316
Good to hear from you :)

it says:

-rw-r--r-- 1 username mail 130 Feb 5 16:54 /etc/valiases/virtualdomain.com
 

gordita

Well-Known Member
Aug 14, 2001
113
0
316
The pertinent line in /var/log/exim_mainlog looks like:

2002-02-05 17:04:08 16YDh9-0003j6-00 => myusername <[email protected]> D=localuser T=local_delivery

I would expect to see:

2002-02-05 17:04:08 16YDh9-0003j6-00 => otherusername <[email protected]> D=localuser T=local_delivery
 

gordita

Well-Known Member
Aug 14, 2001
113
0
316
/scripts/fixpop

I found that running /scripts/fixpop on the main username for each domain fixes the problem, but it sticks the mail in
/home/mainusername/mail/mainusername/inbox
instead of in:
/home/mainusername/mail/inbox
like it did before... is that a problem?
 

gordita

Well-Known Member
Aug 14, 2001
113
0
316
/scripts/fixpop solution

Okay, I ran the /script/fixpop program on the accounts and they seems to be recieving their mail properly, but one side effect I\'ve noticed is that in their cpanel add/remove mail accounts page their main address is now listed twice... it\'s in there once as the main account (with no @virtualdomain.com after it) and then listed a second time just like a normal address. Is this a problem?