Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

exim/Sendmail error

Discussion in 'E-mail Discussion' started by ZapX.net, Jan 19, 2006.

  1. ZapX.net

    ZapX.net Well-Known Member

    Joined:
    Feb 24, 2005
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Sidman, PA
    hi,

    Anytime sendmail is called; every time exim is started, whm tries to send mail, etc, I get this error:

    Any ideas why this is? Exim is failing as a result, and WHM can't send emails.

    Thanks,
    Brandon
     
  2. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    890
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    This Planet
    Are u using /usr/sbin/sendmail is some script?

    Anup
     
  3. ZapX.net

    ZapX.net Well-Known Member

    Joined:
    Feb 24, 2005
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Sidman, PA
    Can you rephrase that? I don't get what you meant.
     
  4. ZapX.net

    ZapX.net Well-Known Member

    Joined:
    Feb 24, 2005
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Sidman, PA
    By the way, I should note that I've already tried /scripts/eximup a few times, and it's also failed.

    Edit:

    Here's the result of eximup; interesting.

    Brandon
     
    #4 ZapX.net, Jan 19, 2006
    Last edited: Jan 19, 2006
  5. anup123

    anup123 Well-Known Member

    Joined:
    Mar 29, 2004
    Messages:
    890
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    This Planet
    logging a ticket with cpanel should/would help you on that. I thought you were using "path_to_sendmail" in some scirpt.

    Anup
     
  6. leedzinh

    leedzinh Registered

    Joined:
    May 11, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    151
    i got same error please help me
     
  7. ZapX.net

    ZapX.net Well-Known Member

    Joined:
    Feb 24, 2005
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Sidman, PA
    hi,

    Guess I could do that, but thought maybe someone might have come across the issue before or have suggestions as to how to fix it.

    Thanks,
    Brandon
     
  8. ZapX.net

    ZapX.net Well-Known Member

    Joined:
    Feb 24, 2005
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Sidman, PA
    Fix

    hi,

    I got it fixed.

    Note to the user who said this problem was also happening for you: I'll give the fix below, but this is on FreeBSD, so it may not work if you are on another OS.

    I tried reinstalling port mail/exim through WHM. However, it complained about a missing file within security/openssl. It tried reinstalling that but the older version already existed, so it wouldn't overwrite it.

    Then in SSH, I went to /usr/ports/security/openssl
    Code:
    cd /usr/ports/security/openssl
    And used:
    Code:
    make deinstall
    Went back to whm, installed the openssl port. Then tried installing the mail/exim port again.

    Now it seems to work, and sendmail doesn't give me that error anymore. :D

    Brandon
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice