The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EXIM Slow Sending, PLEASE HELP!

Discussion in 'General Discussion' started by mind-field, Apr 30, 2004.

  1. mind-field

    mind-field Active Member

    Joined:
    Sep 28, 2002
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    This is very importaint! I need to configure my cPanel server (P4 2.8GHz HT, 1gb RAM) so that it can send many emails at once. It seems to only be able to send an avg of 11/s and I have a very large mailing list that must have a higher average. I heard people achieving 42 emails/s by queueing it only, and then maintaining a minimum of 127 EXIM queue processes, but I am not sure how to do that. PLEASE HELP!! I am paying for a server I cannot get to send the email as needed!

    The mail just continues to build up in the queue and soon becomes over 1,000. I don't really care about load, since it is a dedicated mailing list server.

    I do not have the mailscanner enabled to speed things up, I have a blank file in /etc/blank

    Here is my exim.conf config:

    PHP:
    smtp_accept_max 100
    deliver_queue_load_max 
    100
    smtp_accept_queue 
    150
    # smtp_accept_queue_per_connection = 1000
    # queue_run_in_order = false
    timeout_frozen_after 5h
    split_spool_directory 
    true
    retry_interval_max 
    12h
    # queue_only = true
    auto_thaw 60s
    queue_run_max 
    500
    remote_max_parallel 
    10
    system_filter
    =/etc/blank

    Thanks and God Bless!
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Since this hasn't really got anything to do with cPanel, I'd suggest that you head on over to the exim mailing list at http://www.exim.org where they will be able to help you with a much broader base of experience.
     
  3. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    timeout_frozen_after = 4d
    ignore_bounce_errors_after = 6h
    auto_thaw = 6h
    queue_only_override = false
    smtp_accept_max = 250

    This is what we have been testing for a few days. Spams are really overrunning a few servers we have. All inbound getting stuck in the queue.
     
Loading...

Share This Page