EXim: SMTP Auth Problem

mirfan

Active Member
Nov 24, 2008
27
0
51
I am using two exim instance one for SMTP sending emails and one for
POP/IMAP to receive emails.
I tried to configure SMTP authentication via creating
/etc/exim/passwd.client file which contains all my domain users with
password.

-rw-r--r-- 1 root root /etc/exim/passwd.client

$ cat /etc/exim/passwd.client (manually inserted those users,pass)
myuser1:secret1
myuser2:secret2
myuser3:secret3

exim.conf related snip:
never_user = root

begin authenticators
plain:
driver = plaintext
public_name = PLAIN
server_prompts = :
server_condition = ${if eq{$auth3}\
{lookup{$auth2}lsearch{/etc/exim/passwd.client}{$value}fail}}
server_set_id = $auth2

login:
driver = plaintext
public_name = LOGIN
server_prompts = "Username:: : Password::"
server_condition = ${if eq{$auth2}\
{lookup{$auth1}lsearch{/etc/exim/passwd.client}{$value}fail}}
server_set_id = $auth1

Email Client OutLook related snip:

Account Type >> POP3
Tools >> Options >> Email Accounts >> [email protected] >> Incoming Mail
server >> IMAP/POP3 server IP
Tools >> Options >> Email Accounts >> [email protected] >> Outgoing Mail
server >> SMTP server IP
Tools >> Options >> Email Accounts >> [email protected] >> Outgoing Mail
server >> More Settings >> Outgoing Server

(SELECTED) My outgoing server (SMTP) requires authentication.
(SELECTED) Logon using username: myuser1 password: secret1

But as soon as i send email it stuck in outlook outbox never reaches to
SMTP server. As soon as i uncheck SMTP requires authentication mails
delievers properly.
Please let me know how to configure SMTP authentication. I need this
because to make is secure and no one can abuse SMTP server.

Exim version 4.6 i am using on CPANEL on CentOS 5.