The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim - SMTP Error (state 9): 550 relay not permitted

Discussion in 'E-mail Discussions' started by lloyd_tennison, Oct 9, 2005.

  1. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    UPCP update Exim -then kills all email

    For the last several days, every time upcp runs - it tries to update exim to 4.54. It then totally trashes the system removing sendmail and not allowing any incoimg or outgoing mail - says all accounts are invalid. What is even stranger - when I run /scripts/eximup - it reinstall 4.52 and all is fine.

    First - why are they not pulling from the same source.

    Second: Thank heavens they are not.

    Third. WHat do do about this.

    OS -Fedora Core 4

    Logwatch alos tells me every day that Exim is corrupt - whch it seems to be.
     
  2. bloggz

    bloggz Member

    Joined:
    Jul 20, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hello there,

    We've been having a few problems with Exim over the past week, it goes through phases of refusing to receive mail returning the mail to sender with:

    PERM_FAILURE: SMTP Error (state 9): 550 relay not permitted

    I then run a

    /scripts/eximup --force

    and all is fine and dandy utill it happens again the next day. Clients can still check the pop boxes but nothing new is ever in them, in fact the only indicator I get is when I haven't received any new mail for a few hours. Originally I thought this was down to a nightly yum update running, so I disabled that, but it's still happening, I checked the Yum log and the last update was on the 6th Oct 2005, but the 550 relay thing has happened twice since. I've also run /scripts/mailperm and /scripts/fixeverything

    We're running: WHM 10.6.0 cPanel 10.8.0-C57, Fedora i686 (FC4) - WHM X v3.1.0

    Thanks for any insight people can provide. I really don't fancy rebuilding exim every morning ;)
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Appears to be an FC4 specific problem considering recent threads about exim on FC4. You'll probably have to deal directly with cPanel to get it resolved.
     
  4. bloggz

    bloggz Member

    Joined:
    Jul 20, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Booger, thanks for the info tho
     
  5. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    I opened a ticket with Cpanel and here was their response and fix:

     
    #5 lloyd_tennison, Oct 10, 2005
    Last edited: Oct 12, 2005
  6. Arsalan

    Arsalan Well-Known Member

    Joined:
    Jan 5, 2002
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    And how do we do that ?
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You edit your /etc/yum.conf and add exim* to the exclude list.
     
Loading...

Share This Page