The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim smtp not responding

Discussion in 'E-mail Discussions' started by typhon, May 20, 2004.

  1. typhon

    typhon Well-Known Member

    Joined:
    Feb 17, 2004
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    I dont know what is up with this. I am using:
    WHM 9.2.0 cPanel 9.3.0-R5
    RedHat Enterprise 3 - WHM X v3.1.0

    I woke up this morning and exim just wouldn't respond. It seems to be started ok and it even restarts okay.

    I ran the fix db/permissions on the accounts.. that didn't do anything. Now I just dont know what to do. I just cant get in to send an email!

    Anyone run into this issue before?
     
  2. icanectc

    icanectc Well-Known Member

    Joined:
    Mar 10, 2003
    Messages:
    344
    Likes Received:
    0
    Trophy Points:
    16
    Need more info...

    Can you check the pop accounts and send mail and it just wont send and received anything as if the system ate the email or do you get an error when checking the pop account??

    Are you running an RBL's in exim config

    Are you running MailScanner and/or SpamAssassin?

    Login to SSH as root and
    tail -f /var/log/exim_mainlog and
    tail -f /var/log/maillog

    any errors??
     
    #2 icanectc, May 20, 2004
    Last edited: May 20, 2004
  3. typhon

    typhon Well-Known Member

    Joined:
    Feb 17, 2004
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    it doesn't respond in the logs, and there are no errors.
    the firewall is setup to let that port through. so this is just odd. all pop3 mail checking works and get delivered.

    simply just smtp. my cronjob from root sent the file okay.

    I am using both mailscanner and spamassassin.
     
  4. icanectc

    icanectc Well-Known Member

    Joined:
    Mar 10, 2003
    Messages:
    344
    Likes Received:
    0
    Trophy Points:
    16
    disable mailscanner

    by /etc/init.d/MailScanner stop

    and see if mail starts working...

    I had a problem EXACTLY like this... How long have you been running mailscanner? Did you rcently try to install it or have been using it for a while?


    Try it with MailScanner off and see if the mail works and let me know.
     
  5. typhon

    typhon Well-Known Member

    Joined:
    Feb 17, 2004
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    this never seemed to work oddly enough. whats even more baffling is that the cronjobs will send email to my accounts so why would i not be able to do it remotely when the firewall is not setup to block the port...

    interesting? any ideas guys?
     
Loading...

Share This Page