EXIM/SMTP/Relay Help Needed for JNOS (Ham Radio BBS)

Operating System & Version
CENTOS 7.9 kvm [server]
cPanel & WHM Version
v98.0.9

n2nov

Member
Dec 28, 2011
5
0
51
cPanel Access Level
Root Administrator
Both my JNOS (ham radio bbs on the 44/8 network or n2nov.ampr.org) and my hosting server for client accounts resides on the same box in a COLO. With the current Exim handling the commercial clients, I just wanted to see how to set up to pass through to JNOS as a relay. The Exim on the host box is set up in JNOS as a non-44 network gateway for SMTP. I am sick of incoming or outgoing mail between JNOS and services like GMAIL not allowed to go through. So far email with MSN and Yahoo are working, but I fear the end is near because of what GMAIL is doing.

The question is how do I set up the Exim to accept mail from GMAIL on behalf of the n2nov.ampr.org domain, take care of the secret DKIM/SPF handshaking and then forward it on to the IPIP encapped 44 address on the same box [through the tunnel] and also in reverse)?

Here are the errors received from GMAIL:

OUTBOUND TO GMAIL
-----------------------------------------------------------------------------
This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:
[email protected]
host gmail-smtp-in.l.google.com [142.251.4.26]
SMTP error from remote mail server after end of data:
550-5.7.26 This message does not have authentication information or fails to
550-5.7.26 pass authentication checks. To best protect our users from spam, the
550-5.7.26 message has been blocked. Please visit
550-5.7.26 https://support.google.com/mail/answer/81126#authentication for more
550 5.7.26 information. n41si1929133wms.89 - gsmtp

Reporting-MTA: dns; server.domain.net

Action: failed
Final-Recipient: rfc822;[email protected]
Status: 5.0.0
Remote-MTA: dns; gmail-smtp-in.l.google.com
Diagnostic-Code: smtp; 550-5.7.26 This message does not have authentication information or fails to
550-5.7.26 pass authentication checks. To best protect our users from spam, the
550-5.7.26 message has been blocked. Please visit
550-5.7.26 https://support.google.com/mail/answer/81126#authentication for more
550 5.7.26 information. n41si1929133wms.89 - gsmtp

ForwardedMessage.eml
Subject:
test 11:03PM
From:
[email protected]
Date:
10/11/2021, 11:03 PM
To:
[email protected]

test

--
73 de N2NOV
[email protected]
-----------------------------------------------------------------------------


INBOUND FROM GMAIL
-----------------------------------------------------------------------------
R:211002/1518Z [email protected]#NNJ.NJ.USA.NOAM LinBPQ6.0.21

Hello, Charles
I am trying to send you an email and my emails to you bounce back for the following:
Your message couldn't be delivered to [email protected]
because the remote server is misconfigured.
See technical details below for more information.
The response from the remote server was:
550 Please turn on SMTP Authentication in your mail client.
mail-qv1-f49.google.com [209.85.219.49]:39441 is not
permitted to relay through this server without authentication.

Anyway, I just wanted to check if you still have issues making a NetROM connection
to my node?
From my end, I see things are working fine. But wanted to make sure.

73 de AL0Y
-----------------------------------------------------------------------------
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,491
1,008
313
cPanel Access Level
Root Administrator
Hey there! I think this is a bit beyond what cPanel support intends to happen with Exim. Normally Exim is the only mail handler on the machine, running independently of other tools. I'm a firm believer of "most anything is possible" but in this case you'll need to do some research to see how those interact as I don't have any advice on my end for this particular situation.
 

n2nov

Member
Dec 28, 2011
5
0
51
cPanel Access Level
Root Administrator
Hey there! I think this is a bit beyond what cPanel support intends to happen with Exim. Normally Exim is the only mail handler on the machine, running independently of other tools. I'm a firm believer of "most anything is possible" but in this case you'll need to do some research to see how those interact as I don't have any advice on my end for this particular situation.
I would think that it would be some sort of proxy or relay situation. Maybe the ham radio part is the stumbling block. Think of it as another domain on another server. How would the main Exim accept traffic destined for another location, but use the Exim to handle the DKIM/SPF bits to satisfy GMAIL in both directions?
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,491
1,008
313
cPanel Access Level
Root Administrator
There isn't a way to do that - that was just the example if it was a remote domain.

You may want to post this question directly to the Exim users list to see if someone else has ideas on how to make these types of customizations.
 

mtindor

Well-Known Member
Sep 14, 2004
1,416
80
178
inside a catfish
cPanel Access Level
Root Administrator
Interesting, but how can my Exim be set up as the smarthost instead?
I'm an admin over on RR. Why don't you PM me over there, or email my username @gmail . I think we can get this figured out assuming we can work privately on this and actually expose all the useful email information instead of having to deal with the obsfuscation that we have to deal with here.

I'll shoot you a PM on RR and you can respond if you want.

Mike
 
  • Like
Reactions: cPRex

mtindor

Well-Known Member
Sep 14, 2004
1,416
80
178
inside a catfish
cPanel Access Level
Root Administrator
@n2nov and I got this sorted out. We (he) just added a section to the ROUTERSTART area in Exim Config advanced editor, we (he) added the file /etc/staticroutes with a couple of lines in it to direct certain mail traffic, and it's working fine.

Mike
 
  • Like
Reactions: cPRex and n2nov

n2nov

Member
Dec 28, 2011
5
0
51
cPanel Access Level
Root Administrator
@n2nov and I got this sorted out. We (he) just added a section to the ROUTERSTART area in Exim Config advanced editor, we (he) added the file /etc/staticroutes with a couple of lines in it to direct certain mail traffic, and it's working fine.

Mike
In effect, the JNOS BBS on the 44 network itself becomes the smarthost for the EXIM after adding an smtp relay statement with the address of the EXIM in the autoexec.nos file of JNOS.