The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim started giving error this morning

Discussion in 'General Discussion' started by rfrench10, May 22, 2005.

  1. rfrench10

    rfrench10 Well-Known Member

    Joined:
    Feb 19, 2004
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    New York
    :(
    LOG: MAIN
    Operator or semicolon missing before &SYH at /etc/exim.pl.local line 38.
    LOG: MAIN
    Ambiguous use of & resolved as operator & at /etc/exim.pl.local line 38.
    ====================
    The above error started this morning. I tried to reseteximtodefaults but it said I needed to force an install. I forced a reinstall of exim but this error continues. The email does eventually get delivered. At least some of it does, from my tests. Has anyone encounted this issue before? When I look a the exim.pl.local file it seems to be encrypted, starting on line 38. the whole file is only 2KB large.

    :confused:
     
  2. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    We started receiving the same thing and sending mails from one machine to the other is giving the message:

    SMTP error from remote mail server after RCPT TO:<>:
    host []: 550- []:43585 is currently not permitted to relay
    550-through this server. Perhaps you have not logged into the pop/imap server
    550-in the last 30 minutes or do not have SMTP Authentication turned on in your
    550 email client.

    Running standard fix scripts now:

    /scripts/updatenow
    /scripts/upcp --force
    /scripts/exim4 --force
    /scripts/convertemails
    /scripts/fixeverything
     
  3. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    That didn't fix it. :(
     
  4. Nico

    Nico Well-Known Member

    Joined:
    Dec 5, 2001
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Edmond, OK
    Getting the same errors here as well.
     
  5. techark

    techark Well-Known Member

    Joined:
    May 22, 2002
    Messages:
    280
    Likes Received:
    0
    Trophy Points:
    16
    same thing here.

    Any one submited a ticket or bug report?
     
  6. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    I put in a ticket just a bit ago.
     
  7. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Just did:

    mv /etc/exim.pl.local to /etc/exim.pl.local.
    /scripts/exim4 --force

    That did absolutely nothing also.
     
  8. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Moving to Edge and --force for upcp and exim did not help either.
     
  9. datasuppliesuk

    datasuppliesuk Registered

    Joined:
    Dec 10, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    exim.pl.local

    Does anyone have access to a server where by the exim.pl.local still works??

    Would they be so kind as to post it here for us to see.

    I've been searching the web and can find no reference to that file, So in order to get our server running agin I deleted exim.pl.local and restarted the exim service.

    Result - email server is functional again.


    However an experts opinion would be welcome & any advise / help :cool:
     
  10. BigPete

    BigPete Member

    Joined:
    Dec 4, 2003
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Same issue this morning.. running stable. :confused:
     
  11. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    All of our servers have the new one written from last nights update.
     
  12. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Seen it on a few client servers (don't have the problem on the exim 4.51 #3 build). Here's a clean exim.pl.local (remove the .txt extension)
     

    Attached Files:

  13. BigPete

    BigPete Member

    Joined:
    Dec 4, 2003
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I just ran /scripts/exim4 in the terminal.

    Seemed to have fixed the issue for me for now.
     
  14. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Kris,

    Have you had any response from your ticket? It's definitely file corruption at the end of exim.pl.conf that's causing it.
     
  15. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Thanks as always Chirpy. If you looked at the end of the exim.pl.local file it was complete jibberish. Seems the one from Cpanel is corrupted right now.
     
  16. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    No response on the ticket as of yet. The last upcp I did about 30 minutes ago still resulted in a corrupted local file.
     
  17. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    It ought to be in the exim build. On an affected server, does this fix it:

    edit /etc/cpudate.conf

    note the value of CPANEL=

    Change:

    CPANEL=manual-edge

    Then run:

    /scripts/eximup --force

    Is it fixed?

    Don't forget to set /etc/cpupdate.conf back to what it was. If it isn't fixed, it's certainly very odd.
     
  18. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Yea that's what I did a while back. It hadn't been updated as of an hour ago though.
     
  19. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Looking into this a bit closer:

    /etc/exim.pl.local is not part of the exim builds, so upgrading it won't help. The file is created as part of the process of running /scripts/buildeximconf which /scripts/upcp does any time it's run with automatic cPanel updates enabled (and obviously when you upgrade exim).

    I don't have a server where this is screwing up, so if you are unfortunate to have one, what do you get with:

    ls -la /usr/local/cpanel/etc/exim/perl/

    As this is the directory where it uses information to build /etc/exim.pl.local with.
     
  20. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Found the problem on a clients server.

    There's a file /usr/local/cpanel/etc/exim/perl/boxtrapper.bz2 which is being included as an ASCII file into /etc/exim.pl.local

    To fix:

    mv /usr/local/cpanel/etc/exim/perl/boxtrapper.bz2 /root/
    /scripts/buildeximconf


    If you have MailScanner installed, do the following as well:

    /scripts/mailscannerupdate

    Then either way, restart exim:

    /etc/init.d/exim restart
     
Loading...

Share This Page